WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

#876 closed defect (worksforme)

Icons in front of external links are missing

Reported by: morganestes Owned by:
Milestone: Priority: normal
Component: Trac Keywords: needs-patch
Cc:

Description

It appears that there should be an icon in front of links inside comments on tickets indicating that they're external links, but there's just an empty space where the image is supposed to be.

One example of the markup is:

<a class="ext-link" href="https://make.wordpress.org/chat/">
<span class="icon">&#8203;</span>Slack</a> in #core by morganestes. 
<a class="ext-link" href="https://wordpress.slack.com/archives/core/p1424299563005495"><span class="icon">&#8203;</span>View the logs</a>

The styles that are applied to this include a background image for .ext-link .icon set in trac.css but overridden and set to display:none in wp-trac.css, and inserted content of "\f316" on a.ext-link:before. I can't find any record of that icon on https://developer.wordpress.org/resource/dashicons/, but the dashicons stylesheet loaded indicates it's a download icon, which doesn't seem appropriate in this case.

.dashicons-download:before {
    content: "\f316"
}

Removing the display:none rule from .ext-link .icon in wp-trac.css shows the background image icon but doesn't fix the left padding issue caused by the missing icon styles.

Attachments (3)

missing-link-icons.png (187.7 KB) - added by morganestes 4 years ago.
Screenshot showing missing icons in links
missing-link-icon-markup.png (93.7 KB) - added by morganestes 4 years ago.
Sample markup of a link with missing icon
876.png (271.2 KB) - added by ocean90 4 years ago.

Download all attachments as: .zip

Change History (6)

@morganestes
4 years ago

Screenshot showing missing icons in links

@morganestes
4 years ago

Sample markup of a link with missing icon

@ocean90
4 years ago

#1 @ocean90
4 years ago

Which browser are you using? 876.png is what I can see.

#2 @morganestes
4 years ago

I'm using Opera 27 on Mac. I've tried with incognito mode and no extensions and it's the same, but it's not happening in Opera Beta (28.0) or any other browser I have. Weird.

#3 @morganestes
4 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I just took another look with Opera 28, and everything's looking fine now.

Note: See TracTickets for help on using tickets.