WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#902 closed defect (fixed)

New Theme Uploader fails with ZIP File is empty bug

Reported by: ThemeZee Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

I am not able to upload any theme update with the new Uploader (tested in Chrome, Firefox and IE), because the Uploader throws a "ZIP File is empty" error.

I have attached the theme .ZIP file and a screenshot about the bug.

Attachments (2)

theme-upload-empty-zip-file.png (11.7 KB) - added by ThemeZee 5 years ago.
smartline-lite.zip (631.6 KB) - added by ThemeZee 5 years ago.

Download all attachments as: .zip

Change History (9)

This ticket was mentioned in Slack in #themereview by themezee. View the logs.


5 years ago

#2 @Otto42
5 years ago

This isn't a certain thing, as others seem to be able to upload ZIPs okay.

What are you using to create your ZIP file? Might be helpful to know all the details here, try to figure out the underlying cause.

#3 @iografica
5 years ago

Hi @Otto42, i have the same issue. I use the default mac compression file system. Maybe the problem is the "-" in the file name?

#4 @ThemeZee
5 years ago

I'm using a simple windows batch based on git archive to create the zip file.

#5 @ThemeZee
5 years ago

@iografica: I just tried your suggestion and renamed my theme to smartline..

The upload works fine without the - in the name

#6 @Otto42
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed now. Bug in the uploader being able to see the resulting files for certain characters in zip file names.

#7 @Otto42
5 years ago

Fixed in r1343

Note: See TracTickets for help on using tickets.