WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#923 closed defect (wontfix)

WordPress Theme/Plugin updater is based on folder name rather than theme/plugin name set in file 😕

Reported by: nvartolomei Owned by:
Milestone: Priority: normal
Component: API Keywords:
Cc:

Description

Hello,

I just noticed updates for themes that have folder name Discovery for example, even if I change theme name in style.css I can still see updates, afaik WordPress.org used theme name before to check for updates and not folder name.

The same applies for plugin, some of our clients already did accidental updates. Now I should rename all folders that matches some on WordPress.org, why you don't check theme name too? Or theme author?

Now I can't have fancy names for folders with home made things 😕

Change History (3)

#1 @pento
5 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

Hi there!

That's the expected behaviour. For themes hosted on WordPress.org, we only allow one theme per folder name, and we check for updates based on that folder name.

For themes not hosted on WordPress.org, you must choose a unique folder name - we generally recommend you name it after the site the theme is for, or perhaps prefix it with your name, or your business name.

#2 @nvartolomei
5 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

But if my site is discovery.md? Or make.pro? Why don't check theme author too for example? Why you even changed this behaviour, theme name wasn't good enough?

And once again, have you considered that people will make accidental updates now after you changed this behaviour?

#3 @Otto42
5 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

The theme name is considered, as is the "URI" for plugins. But this has been the way the update check has worked for a very long time.

If you don't want update notifications, use a unique name. The name of your site is a good one to use. We don't have a theme named "discovery.md" or one named "make.pro". Theme directories can have periods in them too.

Note: An alternative is to use an uppercased directory name. We ignore those, because all our slugs are lowercase.

Last edited 5 years ago by Otto42 (previous) (diff)
Note: See TracTickets for help on using tickets.