WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#934 closed defect (invalid)

Close modal glitch

Reported by: edge22 Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

Basically, when you open the modal and close it, everything is fine. But if you follow the below procedure, you'll see it redirects you back to the Featured themes, which aren't the current featured themes.

  1. Open modal
  2. Navigation to either reviews or support forum
  3. Navigate back to modal, and close it.

Video: http://youtu.be/aOPMK0lVJTc

Change History (7)

This ticket was mentioned in Slack in #meta by tomusborne. View the logs.


5 years ago

#2 @edge22
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This has been fixed with the switch to a static page instead of a modal.

This ticket was mentioned in Slack in #meta by tomusborne. View the logs.


5 years ago

#4 @samuelsidler
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#5 @edge22
5 years ago

Issue still exists, but happens when clicking the "Return to themes list" link now.

#6 @obenland
5 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Unfortunately this is not a bug.

Once you navigate away from the single theme view, you're not in the context of the Theme Directory anymore. The moment you click Description you're sending a new request to the Theme Directory, a single theme request at that. With a request for a single theme there is no list loaded, only that one theme. That's why it has to go get additional themes when you navigate away from that.

#7 @edge22
5 years ago

Understood.

Before, it was showing themes in the Featured section that weren't actually featured - when you would refresh, the correct featured themes would display.

Now, it seems it's showing the correct themes, just in a different order (which I would expect to happen on reload anyways).

Thanks for taking a look!

Note: See TracTickets for help on using tickets.