WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#936 closed defect (fixed)

Some themes marked as "live" not showing on the repository

Reported by: BenSibley Owned by:
Milestone: Priority: high
Component: Theme Directory Keywords:
Cc:

Description

My theme, Unlimited, has been closed and marked as live, but is not available on the repo.

@cais has confirmed he is unable to view the theme, and @karmatosed has said she can see it only if logged in IIRC.

From the Newly Approved Themes, it looks like this may be affecting the Boardwalk and Gridsby themes as well. Each of these themes were marked as live 7 days ago which is the same day the new repo design was launched.

References:

Unlimited: https://themes.trac.wordpress.org/ticket/21929
Newly Approved Themes: https://themes.trac.wordpress.org/query?priority=!theme+update&status=approved&status=closed&resolution=live&changetime=30+days..&group=owner&col=id&col=summary&col=changetime&col=resolution&col=priority&col=status&col=owner&report=25&order=priority
Boardwalk: https://themes.trac.wordpress.org/ticket/22562
Gridsby: https://themes.trac.wordpress.org/ticket/22762

Change History (5)

#1 @Otto42
5 years ago

  • Cc obenland added

#2 @Otto42
5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I didn't change anything, but those themes seem live to me:

https://wordpress.org/themes/unlimited/
https://wordpress.org/themes/gridsby/
https://wordpress.org/themes/boardwalk/

If the theme-sync is indeed missing some, then reopen this ticket with which ones so that we can examine the logic on the process.

#3 @Otto42
5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Actually, you're right, they're not published for some reason. I'll look into it. However, the timing indicates this may be a one-time event from when we were rolling out the theme sync process last week.

#4 @Otto42
5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Went through all the themes that went live 7 days ago, and those seemed to be the only three affected. I manually set them to published.

If any others crop up in the future, especially from a time period not in that window where we were doing the rollout, then take no manual actions, and re-open this ticket with relevant info. The logic in the sync process looks sound to me, but we won't really know until we find a failure case. Fortunately, manual intervention is a lot easier now.

#5 @BenSibley
5 years ago

Thank you! I received the system email and the theme is now live on the repo.

Note: See TracTickets for help on using tickets.