WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 3 years ago

#942 closed defect (fixed)

[code reference] Incorrect Used By and Uses info for lowercase_octets()

Reported by: jdgrimes Owned by: DrewAPicture
Milestone: Priority: normal
Component: Developer Hub Keywords:
Cc:

Description

See https://developer.wordpress.org/reference/functions/lowercase_octets/

The function is declared inside of redirect_canonical(), and that is likely the cause.

Change History (7)

This ticket was mentioned in Slack in #meta-devhub by sam. View the logs.


5 years ago

#2 @coffee2code
4 years ago

@DrewAPicture: What do you think about this? The lowercase_octets() function should probably (for expediency) be given a docblock that includes @ignore. Though ideally the parser should not create an entry for a function defined within another function.

#3 @DrewAPicture
4 years ago

@coffee2code: I'd say since it's a closure, we should probably skip parsing it. I'll create a core ticket for it.

#4 @jdgrimes
4 years ago

Note that the issue has been fixed in the parser. (But you'll probably still want to skip parsing it.)

This ticket was mentioned in Slack in #meta-devhub by drew. View the logs.


3 years ago

#6 @DrewAPicture
3 years ago

  • Owner set to DrewAPicture
  • Status changed from new to assigned

I've unpublished the reference page and will add a DocBlock with an @ignore tag in core.

#7 @DrewAPicture
3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

DocBlock with @ignore tag added in [core38106].

Note: See TracTickets for help on using tickets.