WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#963 closed defect (duplicate)

Plugin directory: Missing pagination in certain search views

Reported by: netweb Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

https://wordpress.org/plugins/search.php?q=azure -> Showing 1-18 of 21 plugins

Results:

  • Only the first 18 plugins are displayed and there's no pagination, the 3 remaining plugins cannot be viewed

Expected:

  • Pagination links to the right of the page to view page 2, and plugin results 19-21

Change History (3)

#1 @Otto42
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #59.

We're aware of the strange pagination. It's a side-effect of a few different things. On the list.

#2 @netweb
5 years ago

Ahhh.... That again, cool, thanks :)

#3 @coffee2code
5 years ago

Technically this issue is with the count of the results being claimed to exist and not with pagination. The directory lists 30 plugins per page, so all the claimed results would fit.

In this case, the output should really be Showing 1-18 of 18 plugins. I have a "fix" for this incorrect results display, but the true issue with searching, as Otto referenced, goes deeper.

Note: See TracTickets for help on using tickets.