WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

#1257 closed defect (wontfix)

Preventing plugin author fields from being translated

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords: dev-feedback
Cc:

Description

There are some plugin header fields which, in my plugins at least, are not appropriate for translation:

  • Plugin URI
  • Author
  • Author URI

Prior to language packs, I would manually review translations sent to me to ensure that these fields had not been changed. Now that translations are being handled on translate.wordpress.org, these translations are out of my hands.

How can I be assured that a translator or locale moderator does not change one of these fields to show their own name or link for my plugin?

Change History (6)

#1 @samuelsidler
4 years ago

In the plugin header, unless you've added the gettext calls, they shouldn't be translatable at all. Is there an instance where you'd want to add the gettext calls and not want it translated?

#2 @ocean90
4 years ago

This us currently by design, see https://core.trac.wordpress.org/browser/trunk/tools/i18n/pot-ext-meta.php, not specific to translate.wordpress.org.

#4 @netweb
4 years ago

To also add that if any of those fields are translated the translator will see a warning noting that the strings are sufficiently different, they also have to acknowledge that warning.

I couldn't find an exact match of a case where a translator had wrongly translated these of a plugin to cause one of these warnings, so that's a good thing, and as these warnings are logged in the #polyglots-warnings channel on Slack there is kind of a way to track these warnings, but John you've got more than a few plugins so ¯\_(ツ)_/¯

#5 @johnbillion
4 years ago

  • Keywords close removed

The issue is specific to translate.wordpress.org because it's now powering the translations for my plugins and, as a plugin author, I'm unable to moderate these translations.

So:

How can I be assured that a translator or locale moderator does not change one of these fields to show their own name or link for my plugin?

The warning in #polyglots-warnings is handy, but I'm guessing most plugin authors aren't going to keep an eye on that channel. Is this sufficient? Is there another notification that can be set up to alert a plugin author if one of these fields is translated?

#6 @ocean90
4 years ago

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.