WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1547 closed defect (invalid)

New style docs are not editable

Reported by: theMikeD Owned by:
Milestone: Priority: normal
Component: Developer Hub Keywords:
Cc:

Description

The new docs pages don't seem to be editable like the old ones are. Is this by design?

Example: https://developer.wordpress.org/reference/functions/wp_enqueue_script/

Change History (7)

#1 @samuelsidler
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Devhub pulls data from the inline docs in core. If an inline doc is incorrect, you can file a core ticket to fix.

The User Contributed Notes can be submitted by anyone who's logged in.

#2 @SergeyBiryukov
3 years ago

  • Component changed from Codex to developer.wordpress.org

#3 @theMikeD
3 years ago

Was there effort made to ensure that the content present on the old pages is present in the php docblock on a function-by-function (filter, action, etc) basis? If not, how can we see the old page to compare to the new one to ensure information parity?

#4 @theMikeD
3 years ago

For example: https://codex.wordpress.org/Template_Tags/get_posts is quite detailed. The docblock for get_posts is not, and neither is the new doc page for get_posts https://developer.wordpress.org/reference/functions/get_posts/ . In this particular case, it's worse than incomplete because it provides a subset of the actual arguments as if it was a complete list.

How will the current information be preserved? Does the entire current codex page really need to be put into the docblock? How should code fragments be formatted?

Last edited 3 years ago by theMikeD (previous) (diff)

#5 @theMikeD
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#6 @samuelsidler
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

There is an ongoing effort to migrate the data. If you'd like to join, pop into #docs in Slack and get involved. Once the data is migrated, we redirect the Codex page.

This ticket was mentioned in Slack in #meta-devhub by themiked. View the logs.


3 years ago

Note: See TracTickets for help on using tickets.