WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1627 closed defect (fixed)

i18n on developer.wordpress.org

Reported by: ramiy Owned by: coffee2code
Milestone: Priority: normal
Component: Developer Hub Keywords:
Cc:

Description

Fixing the theme i18n.

See the attached patch.

Attachments (1)

wporg-developer.patch (3.3 KB) - added by ramiy 3 years ago.

Download all attachments as: .zip

Change History (7)

#1 @extendwings
3 years ago

Duplicate of #658?

#2 @ramiy
3 years ago

Not duplicate but related.

This ticket is about internationalizing the "developer" site theme (see the attached patch).

#658 is about internationalizing the "developer" site content (parsed documentation from the WordPress source code).

#3 @coffee2code
3 years ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from new to closed

In 2779:

developer.wordpress.org: Make more strings translatable.

Props ramiy.
Fixes #1627.

#4 follow-up: @ramiy
3 years ago

@coffee2code,

In my patch I fixed two files (content-reference.php and content-wp-parser-hook.php),
in your changeset you fixed only one file (content-reference.php).

Basically, it's the same change for both files.
I think you should consider updating the second file too.

#5 in reply to: ↑ 4 @DrewAPicture
3 years ago

Replying to ramiy:

In my patch I fixed two files (content-reference.php and content-wp-parser-hook.php),
in your changeset you fixed only one file (content-reference.php).

Basically, it's the same change for both files.
I think you should consider updating the second file too.

If I remember correctly, we don't actually use content-wp-parser-hook.php anymore for simplicity. The get_template_part() calls toggle for content-{$post_type} only for non-parsed post types since [1675].

I would guess that's why @coffee2code didn't update it with your changes, as it's likely to be removed in the future.

#6 @coffee2code
3 years ago

@ramiy: @DrewAPicture is correct. The content-wp-parser-hook.php template is no longer in use and its removal is one of my pending commits for the next day or two.

Note: See TracTickets for help on using tickets.