WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2242 closed defect (worksforme)

infos about a plugin in the plugin directory on wordpress.org are not shown fully translated while the strings are available in the 100% readme files

Reported by: rkoller Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

After bringing Custom Post Type UI plugin for de_DE and de_DE_formal to 100% for development (trunk), stable(trunk), development readme(trunk) and stable readme (latest release)

https://translate.wordpress.org/locale/de/default/wp-plugins/custom-post-type-ui
https://translate.wordpress.org/locale/de/formal/wp-plugins/custom-post-type-ui

i've noticed that in the plugin directory at first everything remained in english entirely.

https://de.wordpress.org/plugins/custom-post-type-ui/

after a while the header and the content of the description tab used the provided translations inside the readme. the other tabs remained in english.

@zodiac1978 confirmed the issue with one of his plugins. he translated the following link:

https://translate.wordpress.org/projects/wp-plugins/child-theme-check/stable-readme/de/default?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=3402952&filters%5Btranslation_id%5D=46335161

but in the plugin directory the changelog remains in english.

https://de.wordpress.org/plugins/child-theme-check/changelog/

but in his case the installation tab is translated as well and shown in german. maybe the translation was performed before things broke? and one final observation. if i go to:

https://translate.wordpress.org/projects/wp-plugins/custom-post-type-ui/language-packs

the time stamps for the two german language packs are invalid. the formal versions time stamp is dated, the last edit was on the 14th of november. same with the informal version which is only 1 day off. and about the formal language pack, another odd thing is if it would be the pack from march there shouldn't be any translation at all (ok one or two strings tops). but if i take a look at the po file all strings are filled, unsure if the latest version from online but at 100% anyway. odd. If you need any further informations for tracking that issue down let me know. Best regards r.

Change History (4)

#1 @zodiac1978
2 years ago

  • Component changed from Plugin Directory to Translate Site & Plugins

#2 @ocean90
2 years ago

  • Keywords needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme since everything is translated on the plugin pages. To trigger a new language pack I rejected/approved a translation.

#3 @zodiac1978
2 years ago

@ocean90 How long we have to wait for the translation to appear? 12 hours? (It hasn't happened after 30 minutes or even after six hours, what I would have expected ...) What is the exact caching time?

#4 @rkoller
2 years ago

@ocean90 It is working for me now as well. So only rejections and approvals are triggering the generation of a new pack. In case of the CPTUI i am the translation editor and i've translated everything on my own, so no need of any approval and partially new packs were generated while working on the finishing touches. But seemed the system went in some sort of hick up after a while.

Note: See TracTickets for help on using tickets.