WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 8 months ago

#2680 closed defect (fixed)

Plugin Directory: Same id is used twice

Reported by: nico23 Owned by: ocean90
Milestone: Plugin Directory v3.0 Priority: normal
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

You use the same

#screenshots

id twice.

Attachments (1)

sc.png (13.4 KB) - added by nico23 9 months ago.

Download all attachments as: .zip

Change History (6)

#1 @SergeyBiryukov
9 months ago

  • Keywords reporter-feedback removed
  • Summary changed from Same id is used twice to Plugin Directory: Same id is used twice

#2 follow-up: @SergeyBiryukov
9 months ago

  • Keywords reporter-feedback added

Hi @nico23, could you clarify where the duplicate ID is?

I can only see one instance in the source code, and it's the same instance that is displayed on a single plugin page.

@nico23
9 months ago

#3 in reply to: ↑ 2 @nico23
9 months ago

Replying to SergeyBiryukov:

Hi @nico23, could you clarify where the duplicate ID is?

I can only see one instance in the source code, and it's the same instance that is displayed on a single plugin page.

Looks like you have not bothered to look at the source in the browser. I attached a screenshot from Firefox 52 devtools. If its not in the html/php then its created with JS I guess.

data-react-root ?

So you use React on wp.org already but can't be bothered to code tabs. Thats funny. I have no clue about react but what what wp.org plugin dir is doing at this time its not needed at all. Probably even harder to do things and you end up with things like this. I found out about this because in my userscript #2679 I need to take specific care to handle this case.

Last edited 9 months ago by nico23 (previous) (diff)

#4 @SergeyBiryukov
9 months ago

  • Keywords needs-patch added; reporter-feedback removed

Thanks, reproduced now with Chrome dev tools as well.

#5 @ocean90
8 months ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 5454:

Plugin Directory: Replace the #screenshot container when inserting the screenshot slider.

Fixes #2680.

Note: See TracTickets for help on using tickets.