WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 23 months ago

#2802 closed enhancement (invalid)

Credit to initial translator when validator uploads po-file

Reported by: tobifjellner Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Improvement suggestions:
Some validators prefer to do their validation off-line, by downloading all pending strings, check and correct as needed, and then upload the checked translations back to glotpress.
However, in this case, the tracking of the initial translation is lost, and the person who in fact did the translation will not get credit for their contribution.

Suggestion: When a validator uploads an external translation (po-file), glotpress should check each uploaded translated string against pending translations. If a 100% match is found, then this string should be noted as translated by the initial translator and confirmed by the validator, who made the upload.

Since I'm not sure if the translation credits are handled by glotpress or wp-meta. I'll write this ticket in both places.

https://github.com/GlotPress/GlotPress-WP/issues/710

Change History (4)

This ticket was mentioned in Slack in #polyglots by tobifjellner. View the logs.


2 years ago

This ticket was mentioned in Slack in #polyglots by casiepa. View the logs.


2 years ago

#4 @ocean90
23 months ago

  • Resolution set to invalid
  • Status changed from new to closed

The GlotPress issue is the correct one in this case.

Note: See TracTickets for help on using tickets.