WordPress.org

Making WordPress.org

#3061 closed defect (wontfix)

Plugin forums new thread doesn't ask for plugin version or PHP version

Reported by: Shelob9 Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

New threads ask for WordPress version and URL of site, but knowing what version of the plugin and PHP version would be 200-500% more useful.

Change History (6)

#1 @SergeyBiryukov
20 months ago

  • Component changed from General to Support Forums

There's a patch for plugin version on #152.

Not sure about the PHP version, is it really necessary for all plugin authors?

#2 follow-up: @Shelob9
20 months ago

I think PHP version is a very important piece of information to have. Often times out of date PHP version is the issue . Or maybe it's not, but often needs to be ruled out.

#3 @Shelob9
20 months ago

I also think that asking for PHP version is a good opportunity, if someone is using PHP5 to educate them as to how to fix that. Probably with a link to the page to be created via #2996

#4 in reply to: ↑ 2 ; follow-up: @netweb
20 months ago

I think this is too much to ask of users, it's not going to be an easy task for the vast majority of users to find this info

Replying to Shelob9:

I think PHP version is a very important piece of information to have. Often times out of date PHP version is the issue . Or maybe it's not, but often needs to be ruled out.

I'd say that is rarely the case in the PHP 5.x and PHP 7.x world, back not long after dropping PHP 4 that may have been the case but today out of date PHP versions are rarely the cause of plugin issues on the support forums from my observations.

If a plugin developer requires a minimum PHP version for the plugin the plugin should show a notice to the user that they are using an unsupported PHP version and the plugin should be deactivated.

#5 in reply to: ↑ 4 @SergeyBiryukov
20 months ago

Replying to netweb:

If a plugin developer requires a minimum PHP version for the plugin the plugin should show a notice to the user that they are using an unsupported PHP version and the plugin should be deactivated.

There's also a plan to introduce a minimum PHP version header in #2952.

#6 @Clorith
14 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Closing this out as wontfix, we're also looking to remove the WordPress version field to make things easier on the users, and as mentioned if there's a minimum requirement plugin authors should handle that gracefully. Users rarely know what version they are using in the first place and this would just add a confusing form element for them.

Note: See TracTickets for help on using tickets.