WordPress.org

Making WordPress.org

#3426 closed enhancement (wontfix)

Extend CloudUp embed to support new "direct link"

Reported by: sterndata Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

This embeds:

https://cloudup.com/iVIymgQsSh0

This does not:

https://cldup.com/u_UNHwGrvVr/ClCQ8R.png

The latter link provides access only to the image in question, while the first provides links to all of the uploaders images. See https://cloudup.com/blog/a-new-home-for-cloudup-direct-links

Change History (4)

#1 @obenland
18 months ago

@clorith Is this something that would be a Core-first change?

#2 @netweb
18 months ago

Yes, the new CloudUp URLs should be added to core, bbPress will then just use that automagically

https://core.trac.wordpress.org/query?status=!closed&component=Embeds

This ticket can then be closed as a dupe of the core ticket once created :)

#3 @Clorith
18 months ago

I don't think this is a possibility, that's a direct link to a file, so no oEmbed. The cloudup.com link has an oEmbed endpoint defined.

#4 @Clorith
17 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Closing this, as it's not a new endpoint that's been created by CloudUp, just a new direct link URL.

If anything is going to force auto-embedding images of a direct non-oEmbed link, core should be handling it by it self and we'll inherit that.

Note: See TracTickets for help on using tickets.