WordPress.org

Making WordPress.org

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#3443 closed defect (fixed)

Unable To Submit Plugins To WordPress.org

Reported by: varunms Owned by: ocean90
Milestone: Priority: highest omg bbq
Component: Plugin Directory Keywords: has-patch
Cc:

Description

I have been trying to submit a new plugin in wordpress.org plugin directory for the past 5hrs -6hrs but not able to.

I keep getting ( Could not insert post into the database ) Error

Screenshot : http://s.svarun.in/kP

Attachments (1)

3443.patch (1.1 KB) - added by ocean90 16 months ago.

Download all attachments as: .zip

Change History (5)

#1 @ocean90
16 months ago

  • Keywords needs-patch added; dev-feedback removed

Caused by Plugin_Directory::filter_wp_insert_post_data() which enforces empty date values to be used for new plugin posts. The database error is Incorrect datetime value: '' for column 'post_modified' at row 1.

@ocean90
16 months ago

#2 @ocean90
16 months ago

  • Keywords has-patch added; needs-patch removed

#3 follow-up: @ocean90
16 months ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 6592:

Plugin Directory: Pass post_date and post_modified to wp_insert_post() when creating a new plugin post.

Prevents an invalid post_modified value due to the Plugin_Directory::filter_wp_insert_post_data() filter.

See #2605.
Fixes #3443.

#4 in reply to: ↑ 3 @varunms
16 months ago

So its fixed now ? can i try uploading a plugin ?

Replying to ocean90:

In 6592:

Plugin Directory: Pass post_date and post_modified to wp_insert_post() when creating a new plugin post.

Prevents an invalid post_modified value due to the Plugin_Directory::filter_wp_insert_post_data() filter.

See #2605.
Fixes #3443.

Fixes #3443.
}}}

Note: See TracTickets for help on using tickets.