WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 20 months ago

#354 closed defect (fixed)

Encoding issue in WP.org notifications

Reported by: SergeyBiryukov Owned by: coffee2code
Milestone: Priority: normal
Component: Profiles Keywords:
Cc:

Description

Previously: #wp21542

In my WP.org profile, I've set a notification for my name in Cyrillic ("Сергей", 6 letters). It seems to work fine, however, I also get notifications for six question marks in a row (??????, see this post on Polyglots for an example).

Change History (12)

#1 @Otto42
5 years ago

  • Owner set to coffee2code
  • Status changed from new to assigned

@coffee2code: You might want to take a look at this, probably some character encoding issue in the notifications code.

#2 follow-up: @SergeyBiryukov
4 years ago

Still getting notifications each time someone writes "??????" on the forums.

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

#3 in reply to: ↑ 2 @SergeyBiryukov
4 years ago

...or in a BuddyPress ticket.

#4 follow-up: @coffee2code
4 years ago

@SergeyBiryukov: I just pushed up a bunch of updates for the notifications code. I created the same notification rule as you have ("Сергей") for myself and have since gotten the "??????" notifications as you reported (while the old code was still in use). When testing with the new code while sandboxed, I was unable to reproduce the issue. Now that the new code is live, I'll continue to monitor if the issue persists. If so, I'll get those errant emails and investigate.

#5 in reply to: ↑ 4 @SergeyBiryukov
4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to coffee2code:

Now that the new code is live, I'll continue to monitor if the issue persists. If so, I'll get those errant emails and investigate.

Cheers! Closing as fixed then, will reopen if it happens again.

#6 @SergeyBiryukov
3 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

@coffee2code: Got a notification for a comment on lt.wordpress.org:

[wporg-match] on Lithuania (match: ??????)

#7 follow-up: @SergeyBiryukov
3 years ago

Got a notification for this comment as well:

[wporg-match] Stephen Edgar on WordPress Trac (match: ??????)

#8 in reply to: ↑ 7 @netweb
3 years ago

Replying to SergeyBiryukov:

Got a notification for this comment as well:

[wporg-match] Stephen Edgar on WordPress Trac (match: ??????)

That was me on a Mac using CTRL+CMD+SPACE and selecting the "thumbs up" emoji :+1:

#9 @SergeyBiryukov
3 years ago

[wporg-match] Mosterd3d on WordPress Trac (match: ??????) (ref)

#10 follow-up: @coffee2code
2 years ago

@SergeyBiryukov: Just check in, is this still an issue you're seeing?

#11 in reply to: ↑ 10 @SergeyBiryukov
2 years ago

Replying to coffee2code:

Just check in, is this still an issue you're seeing?

Yep, the latest notification was 4 months ago from this topic. For a quick test, just post "??????" somewhere and I'll tell you if I get it :)

#12 @coffee2code
20 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

@SergeyBiryukov: I don't believe this is still an issue. Since this ticket was opened I've had a notification for "Сергей" set up so I could see the problem firsthand. I was able to verify getting notifications for occurrences of "??????" for awhile, but eventually that stopped. I haven't received an errant "??????" notification in many many months.

I recently posted to the support forums from a test account with "??????" in the reply content and haven't received a notification about it.

As such, I'm going to close this as fixed.

Note: See TracTickets for help on using tickets.