WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#365 closed defect (invalid)

WordPress.org SVN URI wrong

Reported by: wpsmith Owned by:
Milestone: Priority: normal
Component: General Keywords:
Cc:

Description

Currently on https://wordpress.org/download/svn/ the command for SVN checkout is wrong.

It currently is:
svn co http://core.svn.wordpress.org/trunk/

and it should be
svn co https://core.svn.wordpress.org/trunk/

Change History (9)

#1 @bpetty
6 years ago

Technically, it should be https://develop.svn.wordpress.org/trunk/ now.

#2 @SergeyBiryukov
6 years ago

  • Component changed from wordcamp.org to General
  • Keywords has-patch removed

#3 follow-up: @Otto42
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

SVN doesn't require nor benefit from forced SSL at present.

bpetty: The core install is still at core.svn, not develop.svn. The code at develop.svn is what you get pre-build, before grunt runs and such.

#4 in reply to: ↑ 3 @bpetty
6 years ago

Replying to Otto42:

SVN doesn't require nor benefit from forced SSL at present.

It does for committers, and it doesn't hurt for regular users either.

bpetty: The core install is still at core.svn, not develop.svn. The code at develop.svn is what you get pre-build, before grunt runs and such.

As the top of the page mentions: "This page only applies to developers, if it's all Greek to you, don't worry!"

And since it's for developers, I don't see why it shouldn't point to the (actually) original source code that we really do prefer contributors generate patches against.

#5 @bpetty
6 years ago

Additionally, it would likely really help if that page also linked to the SVN page in the handbook.

#6 @Otto42
6 years ago

But that is a page under /download, which is why I don't think it needs to have detailed developer information. The "download" would be expected to be the built version, aka, core.svn. Not the developer version.

While I think that page does need a bit of a rewrite, I would be more inclined to remove any developer mentions or links from it, because of the location. Additionally, we *don't* want people getting a copy of develop.svn unless they're doing development. You would not want to run a live install off develop.svn, you'd want to run it off core.svn.

#7 follow-up: @wpsmith
6 years ago

I am probably doing something wrong then, but in TortoiseSVN, using the non-secured version results in a failure. If I change the repo url to https://core.svn.wordpress.org/trunk/ then it works. Strange.

http://images.wpsmith.net/screenshots/9QL.png

#8 in reply to: ↑ 7 @SergeyBiryukov
6 years ago

Replying to wpsmith:

I am probably doing something wrong then, but in TortoiseSVN, using the non-secured version results in a failure.

Could not reproduce, it works for me without https.

#9 @wpsmith
6 years ago

Ok, error is on my end. Will investigate. Thank you.

Note: See TracTickets for help on using tickets.