WordPress.org

Making WordPress.org

Opened 9 months ago

Closed 7 months ago

Last modified 7 months ago

#4051 closed enhancement (wontfix)

Indicate GTE role in translation contributor page per project

Reported by: tobifjellner Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description (last modified by tobifjellner)

In the page where translation contributors are listed per translation project (for example https://translate.wordpress.org/projects/wp-plugins/ninja-tables/contributors ) a couple of things need to be made more clear.

  1. When it says "Editors: None" that is not fully true, since there still are General Translation Editors and also may be category translation editors (for instance "all plugins") that have been working on the translation.

Suggestion: Change the line head to "Project Translation Editors:"

  1. In the list of contributors, add a (editor) after each user, who already has editor rights with regards to the project in question.

With these changes, we'd see less requests from plugin/theme developers, who ask us to assign PTE rights to several GTE's...

EditAdd: Especially since the page higher up says: "If a locale has no editor yet then you should probably make a request."

Change History (6)

#1 @tobifjellner
9 months ago

  • Description modified (diff)

#2 @garrett-eclipse
9 months ago

This would be very helpful, many unnecessary requests are caused by this confusion.

#3 @peexy
9 months ago

I agree, that would be really useful!

#4 @Luciano Croce
9 months ago

Very useful!

#5 @ocean90
7 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Closing as wontfix since the view should only list the editors assigned for the current plugin/theme.

#6 @tobifjellner
7 months ago

@ocean90 I'm not saying that we should list everyone who has editor access.
A typical scenario is that someone has suggested 50 not too good translations. As a GTE, while reviewing these, you correct 70-80 percent of the strings.
Suddenly in the translation contributor view, the plugin developer thinks:
"Hey. This tobifjellner has translated most part of my plugin. But he's not been assigned as editor yet. Let's go ahead and nominate him."

So I was just suggesting some kind of asterisk, or whatever, to indicate that someone who has contributed translations while not being a PTE, still already has editor access.

Note: See TracTickets for help on using tickets.