WordPress.org

Making WordPress.org

Opened 4 months ago

Closed 4 months ago

#4279 closed enhancement (duplicate)

Add locale translation status to the Plugin Directory.

Reported by: Luciano Croce Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords: has-screenshots
Cc:

Description

In addition to ticket #4272 (please) adds translation status to the Plugin Directory to indicate the actual status how translated for the current locale the plugin is.

For example: "Translated in en_GB: 95% - Translated in es_ES 85% - Translated in fr_FR: 75%" - Translated in de_DE: 65%"

For "Localized Plugins" it would be nice provide the "Current Translation Status" in "Box Summary" on "Plugin Page".

For the Plugins it would make sense to be added in "Box Informations" where also the other information is provided.

I'll provide some screenshot concepts here.

Thanks!

Attachments (5)

locale-translation-status-in-plugin-directory-en-ca.PNG (19.2 KB) - added by Luciano Croce 4 months ago.
Translated in en_CA: 98%
locale-translation-status-in-plugin-directory-de.PNG (19.3 KB) - added by Luciano Croce 4 months ago.
Translated in de_DE: 95%
locale-translation-status-in-plugin-directory-es.PNG (19.3 KB) - added by Luciano Croce 4 months ago.
Translated in es_ES: 95%
locale-translation-status-in-plugin-directory-fr.PNG (19.1 KB) - added by Luciano Croce 4 months ago.
Translated in fr_FR: 90%
locale-translation-status-in-plugin-directory-pt.PNG (19.2 KB) - added by Luciano Croce 4 months ago.
Translated in pt_PT: 90%

Download all attachments as: .zip

Change History (7)

#1 @Luciano Croce
4 months ago

  • Component changed from Plugin Directory to Translate Site & Plugins

#2 @ocean90
4 months ago

  • Keywords 2nd-opinion removed
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #4272, it's just for a different position.

Note: See TracTickets for help on using tickets.