WordPress.org

Making WordPress.org

Opened 4 weeks ago

Last modified 3 weeks ago

#4563 reopened defect

Search results pages on WordCamp Central should be noindex'd

Reported by: jonoaldersonwp Owned by:
Milestone: Priority: normal
Component: WordCamp Site & Plugins Keywords: seo
Cc:

Description

Search results pages, such as https://central.wordcamp.org/?s=cats, should output a meta robots tag with a value of 'noindex, follow',

Change History (7)

#1 @iandunn
4 weeks ago

Is there a Core ticket for that? It seems odd to do that on a per-site basis if it's a best practice.

#2 @jonoaldersonwp
4 weeks ago

I can't see anything in core trac, but given that I'd actually like to see this fixed before the heat death of the universe and without having to fight through the politics of Jetpack vs Core vs basic SEO standards, I'm hoping that we can just fix this here and pretend that everything is okay.

#3 @iandunn
4 weeks ago

  • Resolution set to wontfix
  • Status changed from new to closed

IMO, the low impact wouldn't justify the effort of doing it per-site. I'd rather us focus our limited resources on things that will make a significant impact for organizers/attendees.

#4 @jonoaldersonwp
4 weeks ago

Agreed in principle for most cases, which is why I haven't opened a thousand tickets - but this one is particularly serious and actively harming performance atm, and worth the investment.

#5 @iandunn
4 weeks ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Can you give some details on the performance issues it causes?

#6 @jonoaldersonwp
4 weeks ago

Sure, but, can we please not close tickets like this preemptively when I've put the time and effort in to determine that they're worth the effort/reward trade off?

Search Google for site:central.wordcamp.org inurl:s. The odd Chinese character pages you'll see are from a whole bunch of indexed search result pages where Chinese spam networks are either attempting to generate these kinds of results in order to syphon off SEO value, or, its a crude negative SEO attack.

Either way, this is actively harming our crawl budget, relevance, and site quality for the whole wordpress.org ecosystem.

This is one small example, and just the tip of the iceberg. There are thousands of issues like these, where WP core just doesn't meet basic SEO requirements.

I'd love to see these level of standards implemented throughout WP, but it's just unrealistic that that'll happen any time soon. In the meantime, for every day that passes, Wix grow their market share at our expense. For the relatively low effort required to solve this locally, we should just do so.

Or, we could install a plugin which handles it all for us automatically, eh?

Last edited 3 weeks ago by jonoaldersonwp (previous) (diff)

#7 @iandunn
3 weeks ago

Search Google for site:central.wordcamp.org inurl:s ... this is actively harming our crawl budget, relevance, and site quality

Thanks, that's helpful to see.

Is there a way to objectively measure and demonstrate the harm? I don't think that's necessarily a requirement for doing something here, but it'd make a much more compelling proposal, and would help determine the severity/priority.


There are thousands of issues like these, where WP core just doesn't meet basic SEO requirements... I'd love to see these level of standards implemented throughout WP, but it's just unrealistic that that'll happen any time soon.

I think everybody agrees that WP should have good discoverability out of the box, and implement SEO best practices that are high-impact, ethical, backwards-compatible, etc. So far I don't see any reason this couldn't be done in Core.

I'm well aware that it takes work to make that happen, but I don't think it's as difficult as you believe. If the problem is as big as you suggest, and the solution is as straightforward, then it shouldn't encounter any active resistance, and it's just a matter of going through the normal process.

Since it sounds like there are a lot of small changes to make, and it has the potential to collectively make a big impact, I'd recommend proposing a feature plugin that would collect all of those small changes and bundle them together.

Assuming the proposal is received positively, then you could work with some of your colleagues who are committers to write a plugin that implements those features in a way that would be appropriate for Core. Assuming that the beta-testing proves its usefulness and doesn't reveal any problems with back-compat, edge cases, etc, then it could be committed to Core, and make an impact for millions of sites.

We could run the feature plugin on WordCamp.org to help with beta testing, etc.

Pursuing this for only WordCamp.org, though, seems like the wrong way to go about it. Just like everyone else, Meta committers have very little time, and a lot of competing requests, and our focus needs to be on Meta projects.

Note: See TracTickets for help on using tickets.