WordPress.org

Making WordPress.org

Opened 3 months ago

Last modified 7 weeks ago

#4708 new enhancement

Requirements page is unclear about acceptable versions.

Reported by: leonaves1 Owned by:
Milestone: Priority: normal
Component: General Keywords: reporter-feedback close
Cc:

Description

https://en-gb.wordpress.org/about/requirements/

The requirements page lists minimum and recommended versions but does not list information about what wordpress finds "acceptable", which is something that triggers a warning notice to users.

Ideally the page would say something like:

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.6.20+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities and a notice may appear in the dashboard to indicate this. To ensure you are never at risk of this, try to stay at least on a version of your software that still receives security upgrades (link to https://www.php.net/supported-versions.php).

And the corresponding notice would contain a link to that page.

Change History (2)

#1 @dd32
8 weeks ago

  • Keywords reporter-feedback close added

I'm not entirely sure I follow, @leonaves1 is the suggestion here that we should warn that using what's called out as a "legacy" system should also warn you that running such a system will also show a dashboard warning?

If so, I think this is a wontfix from me.

I believe the core notice also links to the Support Article about updating PHP.

For reference, the current wording:

Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.6.20+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

#2 @leonaves1
7 weeks ago

Yes that is my suggestion, because the warning is shown to end-users, while the maintainer of the systems may be administrators, or businesses of whom the end-users are clients. The fact that you don't fully drop support for 5.6.* implies to me that you have a pragmatic view about these things. As a developer myself I agree that versions should be kept as up to date as possible but this isn't always in control of the developer who might be looking for the information. If I don't have information on what the gap between the version that "will run" and the version that will show our client a warning, the existing information might cause me to estimate a job is smaller than it is, where if I knew upgrading further would remove the warning I would happily tell my manager that and it would take less time overall.

I may have explained this more coherently on slack, so here is the original conversation for reference: https://wordpress.slack.com/archives/C02RQBWTW/p1567269467407400

Note: See TracTickets for help on using tickets.