WordPress.org

Making WordPress.org

Opened 6 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#5041 closed enhancement (worksforme)

Allow CLPTEs to approve Waiting / Fuzzy strings

Reported by: tokyobiyori Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Currently, CLPTEs cannot approve Waiting / Fuzzy strings that have been generated by external users. It would help if this capability was available as it would help us proceed with our projects. We are okay with not having the capability to change strings that have already been approved, but it would help if we could have access to approve strings that have been translated, but are still waiting for moderation.

Change History (7)

#1 @Nao
6 weeks ago

I agree.
Current setup:

  • Only GTEs/PTEs can moderate Waiting/Fuzzy strings submitted by someone else.
  • GTEs/PTEs can overwrite each other's approved translations.

But I think it should be:

  • GTEs/PTEs can moderate Waiting/Fuzzy strings submitted by someone else including other GTEs/PTEs.
  • CLPTEs can moderate any Waiting/Fuzzy strings that are submitted anyone other than GTEs/PTEs.
  • GTEs/PTEs can overwrite each other's approved translations (<- no change here)
Last edited 6 weeks ago by Nao (previous) (diff)

#2 @ocean90
6 weeks ago

  • Type changed from defect to enhancement

@Nao I might be missing something but your comment doesn't mention CLPTE at all?

#3 @Nao
6 weeks ago

@ocean90
You are right, I was thinking one thing and writing another! Edited the second bullet point in the second list. 🤦‍♀️

#4 @akirk
6 weeks ago

Actually it is possible to approve translations submitted by others, as well as fuzzy strings. What's not possible is to override community submitted translations.

So if a waiting or fuzzy translation already has a current translation by a community member, then a CLPTE cannot approve it. But, if there is no such translation, then the CLPTE can approve it (I've just confirmed that with a fuzzy string here).

I suspect this is what we're experiencing here. @tokyobiyori, do you have an example?

#5 @tokyobiyori
6 weeks ago

We're having the issues here:

https://translate.wordpress.org/projects/wp-plugins/the-events-calendar/stable/it/default/?filters%5Btranslated%5D=yes&filters%5Bstatus%5D=waiting

Basically we see a ton of waiting strings that are correct, but we are unable to approve them and this is stopping us from making progress, and at the same time, we see a lot of strings where we are able to approve, and some others where we can, for instance:

https://www.dropbox.com/s/fvww6tjm5u4spsh/Screenshot%202020-02-11%2016.10.52.png?dl=0

Some have the checkbox, some don't... and then we can't approve them at all:

https://www.dropbox.com/s/hv8kksdk0mibmhu/Screenshot%202020-02-11%2016.31.33.png?dl=0

It's kinda frustrating because at the very least, there are no clear instructions as to what a CLPTE can approve and can't, and I've asked a few members of the community if they understand what's happening and nobody has a clear idea on how to proceed.

#6 @ocean90
6 weeks ago

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the links. I just checked a few of them and all of them had a current translation by a community member. You can see them when viewing the history like this or this one. So @akirk is right here.

That's the case where a GTE/PTE now needs to step in and review the translations.

#7 @tokyobiyori
6 weeks ago

Would it be possible to have a guide as to how to proceed? I believe this procedure defeats the purpose of being a CLPTE a bit.

Note: See TracTickets for help on using tickets.