Making WordPress.org

Opened 4 years ago

Closed 6 weeks ago

#5082 closed defect (bug) (duplicate)

Plugins search results is never relevant :(

Reported by: ahrale's profile Ahrale Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Hi,

I opened this ticket previously [here]https://wordpress.org/support/topic/plugins-search-results-is-never-relevant/#post-12520352 & was advised to open it here...

Both on WP plugins page as well as on WP back end plugins search, the results are rarely relevant & accurate.
Some plugins appear on any keyword search results, while relevant ones are not displayed on the 1st page.
For example… try to look for Add Admin CSS plugin by Scott Reilly.
Use keyword “Add Admin CSS” & you’ll find it on 3rd page if you have the patience to keep on looking, after 1st page includes irrelevant results, such as WP Fastest Cache, MetaSlider, Hummingbird & more 🙁
The same issue exists even if you use the author’s name in the search.
Of course, I only gave an example, but it happens a lot, even getting irrelevant results of abandoned plugins.

I cannot understand how WordPress affords such a search engine which is totally the opposite of being user-friendly, has no filter options, such as last update/supported/abandoned & more.

Made my point.
Thanks,
Ahrale

Change History (5)

#1 @joyously
4 years ago

similar to #2753

#2 @Ahrale
4 years ago

Thanks, @joyously

I looked at it & it is perhaps similar,
however, that one is open few years & very chaotic.

I believe in simplicity & clean distractions free design.
I believe the filters should be useful & should include the following:

  1. WP version compatibility.
  2. PHP version compatibility.
  3. The number of active installs.
  4. last update (was updated in the past month/quarter/year)
  5. Functionality: Cache/SEO/Email/Performance/Backup/Admin...)

I believe it should be a live search (jquery)
& that if I type an author name, it should instantly give me the option to choose from all authors with that name (i.e. Scott... results will show all optional family names)

I believe it should work on both back end as well as on wordpress.org/plugins page.

Since it is similar to #2753 which is open few years,
I have no doubts it is about time to apply it.

Thanks again for listening.

#3 @SergeyBiryukov
4 years ago

  • Component changed from General to Plugin Directory
  • Keywords Needs improved algorithm & filter options removed

#4 @gibrown
3 years ago

  • Milestone set to Improved Search

#5 @dd32
6 weeks ago

  • Milestone Improved Search deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is primarily a duplicate of #2753, but also #3338.

I'm marking this as a duplicate of those, purely to ensure that all relevant discussions are consolidated, no matter how long the ticket has been open.

Note: See TracTickets for help on using tickets.