WordPress.org

Making WordPress.org

Opened 4 months ago

Closed 4 months ago

#5283 closed defect (fixed)

Profiles: Accessibility: Remove redundant texts in dotorg profiles

Reported by: audrasjb Owned by: coffee2code
Milestone: Priority: normal
Component: Profiles Keywords: needs-patch
Cc:

Description

In profile pages, there is some redundant information that need to be remove.

The issue is located on contributor’s badges.

Here is the current HTML code:

<li class="odd private is-admin is-member group-no-avatar">
	<span class="screen-reader-text">Accessibility Contributor</span>
	<div class="badge item dashicons badge-accessibility-contributor dashicons-universal-access" title="Accessibility Contributor"></div>
	Accessibility Contributor
</li>

It should be replaced with:

<li class="odd private is-admin is-member group-no-avatar">
	<div class="badge item dashicons badge-accessibility-contributor dashicons-universal-access"></div>
	Accessibility Contributor
</li>

Since profile pages are not open-sourced yet, I tested this new html code in my browser and it doesn't introduce any user facing change, apart improving the readability of this page for screen reader users.

Thanks!
Jb

Change History (2)

#1 @coffee2code
4 months ago

  • Owner set to coffee2code
  • Status changed from new to accepted

#2 @coffee2code
4 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in [16201-dotorg]:

Profiles: Remove redundant text associated with badges to improve accessibility.

Props audrasjb.
Fixes #5283.

Note: See TracTickets for help on using tickets.