WordPress.org

Making WordPress.org

Opened 8 months ago

Closed 8 months ago

#5690 closed defect (invalid)

Very low link contrast in email

Reported by: Otshelnik-Fm Owned by:
Milestone: Priority: normal
Component: Version Control Keywords: reporter-feedback
Cc:

Description

The link in the plugin update email is barely visible: https://paste.pics/487910fb1e8829ce605cf82a9c6d5931

  • What does not correspond to the accessibility of "AA" (WCAG) 2

Level

add inline css in "a" tag:

color: #fff;
text-decoration: underline;

Result: https://paste.pics/02958e07aaac068766a752a7f05febf2

Change History (1)

#1 @dd32
8 months ago

  • Component changed from Plugin Directory to Version Control
  • Keywords reporter-feedback added
  • Resolution set to invalid
  • Status changed from new to closed

The styling of the a tag here appears to be coming from your mail client, not from the default trac/svn html styling.

Looking at an example message in my inbox, Gmail strips a lot of the styles, but I can see the following in the source:

<style>
#msg dl.meta { border: 1px #006 solid; background: #369; padding: 6px; color: #fff; }
...
#msg dl a:link    { color:#fc3; }
#msg dl a:active  { color:#ff0; }
#msg dl a:visited { color:#cc6; }
...
</style>
...
<div id="msg">
<dl class="meta">
<dt>Revision</dt> <dd><a href="http://plugins.trac.wordpress.org/changeset/12345">12345</a></dd>

Note that:

  • The custom link styles aren't being applied in your cae
  • Gmail is stripping both the link colour and the background colour for me
  • The class on the <a> tag daria-goto-anchor is not present in the emails WordPress.org sent, and appears to be added by your mail client.

In the past I've used chrome extensions to alter SVN emails to add colour highlighting, you could probably do that here, or to strip the background colour out of it instead.

Since I know we don't have a custom email template in use here (It's just the default HTML mode of svnnotify - It allows including an external CSS file, but I think that's got less compatibility than the existing styles, and we can't alter the <a> tag directly I don't think), I'm going to close this as invalid as it appears to be working as intended, and is more likely a client bug, or a bug that should be reported upstream to svnnotify.

Note: See TracTickets for help on using tickets.