WordPress.org

Making WordPress.org

Opened 6 months ago

Closed 6 months ago

#5752 closed defect (fixed)

Zero star rating on plugins details page (in WP, not web)

Reported by: zodiac1978 Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

After clicking on the details link from the Yoast plugin in the plugin list table I get a strange behavior. Below the know 1 to 5 star rating there is an additional line with "0 stars", linking to https://wordpress.org/support/plugin/wordpress-seo/reviews/?filter=0

The link just shows all reviews.

On the web page it does not show this behavior:
https://de.wordpress.org/plugins/wordpress-seo/

Attachments (1)

Bildschirmfoto 2021-05-26 um 10.55.23.png (12.3 KB) - added by zodiac1978 6 months ago.
Details page showing non typical 0 star line (here in German website, therefore "0 Sterne")

Download all attachments as: .zip

Change History (3)

@zodiac1978
6 months ago

Details page showing non typical 0 star line (here in German website, therefore "0 Sterne")

#1 @zodiac1978
6 months ago

@clorith already had some ideas how this happens:

That's very likely that weirdness where stars disappeared when something got flagged, so it has 0 as Metadata, I think it was fixed, but might have been a cache in validation kicked up some dust there

Might be worth a meta ticket, since that's on the api side, and not the direct functions dotorg uses to look up ratings (dotorg got better at handling separations and missing data, and I have a suspicion the same enhancements never made it to the api)

#2 @dd32
6 months ago

  • Resolution set to fixed
  • Status changed from new to closed

In this case, the issue is that a review from 2012 quite literally had 0 stars recorded against it.

I've fixed up that review and the UI should show correctly within a few hours.

To protect against this for other plugins (The ratings table has some bad data for 2012-2015 it seems, I can't correct it all retroactively) I've made a change to the library we use to exclude ratings that fall outside of the 1..5 range:

r17382-dotorg
Ratings: Exclude any ratings counts that are not expected.

See https://meta.trac.wordpress.org/ticket/5752
Note: See TracTickets for help on using tickets.