Making WordPress.org

Opened 2 years ago

Closed 21 months ago

#6000 closed defect (bug) (fixed)

WordPress.tv audio does not work when downloading med and high quality video

Reported by: alanjacobmathew's profile alanjacobmathew Owned by: dd32's profile dd32
Milestone: Priority: high
Component: WordPress.tv Keywords: needs-patch
Cc:

Description

Issue: Downloading wp.tv videos in high quality and medium quality does not support audio.

How To Reproduce:

  • Open any wp.tv video
  • Go to the download section and open 'High' and 'Med' resolution.
  • Play the video online or download it.


Change History (6)

#1 @dd32
2 years ago

  • Owner set to dd32
  • Status changed from new to accepted

This appears to be affecting videos uploaded after October 4th.

https://wordpress.tv/2021/10/04/hussain-thajutheen-headless-wordpress-authentication-with-react/ works, but the next added one https://wordpress.tv/2021/10/05/best-practices-for-capturing-images/ doesn't.

I'll follow up with the VideoPress team to see if this was expected.

#2 follow-up: @dd32
2 years ago

Ah, this looks like an intended change - VideoPress is designed for streaming video, not downloading it.

It looks like the audio track was split off from the video track, so there's now an audio-only file which the player plays along side the video.

Eg, the High quality versions is accessible via https://videos.files.wordpress.com/btlXOQX8/video-3ddb79fd2a_mov_dvd.master.m3u8 which is a playlist that plays audio from one file and video from another (The audio-less video we're linking to).

I've followed up with the VideoPress team to find out what tracks are supposed to have Audio, and I'll update this to reflect that.

We may have to remove the download option, other than the original file, but we'll see what they come back with.

This ticket was mentioned in Slack in #wptv by dd32. View the logs.


22 months ago

#4 in reply to: ↑ 2 @dd32
22 months ago

  • Keywords needs-patch added
  • Priority changed from normal to high

Replying to dd32:

Ah, this looks like an intended change - VideoPress is designed for streaming video, not downloading it.
...
We may have to remove the download option, other than the original file, but we'll see what they come back with.

Seems I never came back and updated this ticket after hearing back from the VideoPress team.

tl;dr of it is:

  • If a video is transcoded into a HLS format, all videos for that video (excluding fmt_std, for compatibility) will have no embedded audio track
  • The best way forward here is to remove the download links for any video files which has been transcoded to HLS, which will likely leave us with just the original and perhaps low-quality versions. We can't restore the previous behaviour for WordPress.tv

This ticket was mentioned in Slack in #wptv by dd32. View the logs.


22 months ago

#6 @dd32
21 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 12043:

WordPress.TV: Don't link to the mp4 formats which have no audio, expose the original uploaded file, and add these to the WordPress.tv/api/videos.json API.

Fixes #6000

Note: See TracTickets for help on using tickets.