Making WordPress.org

#6679 closed defect (bug) (fixed)

WordPress.org Plugin Support Forum Search powered by Google not working

Reported by: abitofmind's profile abitofmind Owned by:
Milestone: Priority: normal
Component: WordPress.org Site Keywords: has-patch
Cc:

Description

Reproduction as of 2023-01-13:

  1. Go to the support forum of any plugin, e.g. Redirection.
  2. Look at the titles of the most recent threads on top.
  3. Search for any words in those titles.

Expected: Should yield a result obviously.

Actually: No result at all.
→ People are less likely "to search before the type" then.
→ Higher probability for duplicate content in the support forums.
→ Overally frustrating for all parties involved.

Fixing this hopefully is a small effort for a big gain.

Attachments (1)

Wordpress.org Plugin Forum Search not working.mp4 (274.9 KB) - added by abitofmind 18 months ago.

Download all attachments as: .zip

Change History (6)

#1 @abitofmind
18 months ago

▶️ WordPress.org Plugin Forum Search not working (18sec video, 281 kB, Dropbox)

(for convenience, as this ancient issue tracker cannot show it inline, nor open it in a new tab, but only download it, yikes)

This ticket was mentioned in Slack in #forums by abitofmind. View the logs.


18 months ago

#3 @Otto42
18 months ago

  • Component changed from General to WordPress.org Site

We really didn't need the video. The problem is obviously that the search parameter is not going through to the query. I suspect it's something to do with the new search page.

This ticket was mentioned in PR #168 on WordPress/wporg-main-2022 by @dd32.


17 months ago
#4

  • Keywords has-patch added

Fixes https://meta.trac.wordpress.org/ticket/6679

Props <username>, <username>

### How to test the changes in this Pull Request:

  1. Search from https://wordpress.org/support/plugin/redirection/ with a question mark included, or without..
  2. Notice it doesn't quite work right, but looks like it does
  3. Apply patch.
  4. Perform search again, notice the ? is kept, and that intext:... is included.

#5 @dd32
17 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed via above PR.

Note: See TracTickets for help on using tickets.