Making WordPress.org

Opened 7 months ago

Closed 7 months ago

#7348 closed defect (bug) (fixed)

The console contains 100 + errors if you have a table with 100 records incorrectt use of <label for=FORM_ELEMENT>

Reported by: psmits1567's profile psmits1567 Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords: changes-requested
Cc:

Description

Every time you open a table containing suggestions, you will notice a whole lot of errors in you console!!
This is causing a memory problem, and is caused by the discussion module

The label's for attribute refers to a form field by its name, not its id. This might prevent the browser from correctly autofilling the form and accessibility tools from working correctly.
To fix this issue, refer to form fields by their id attribute.
<label for="feedback_comment">Comment (Optional) </label>

Change History (3)

#1 @spiraltee
7 months ago

This is a bug in the gp-translation-helpers plugin and it's being fixed here - https://github.com/GlotPress/gp-translation-helpers/pull/203

#2 @psmits1567
7 months ago

Thanks I could not find the ticket for this issue in my list of reported bugs

#3 @Amieiro
7 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Resolved here and deployed here.

Note: See TracTickets for help on using tickets.