Making WordPress.org

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#7502 closed enhancement (invalid)

Add a warning on plugin's page when the min req PHP ver is < WP compatiblity

Reported by: juliobox's profile juliobox Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Hey there
I'll be short:
WordPress does not work on PHP5.6 anymore, try it, you'll break your legs in half, the last compat version seems to be 6.2.4.
I suggest to add the same kijnd of warning when a plugin has not been updated since 3 major versions, but with PHP.
Example with my plugin: https://wordpress.org/plugins/secupress/
Today it's still PHP5.6 minimum (because the plugin code is compatible), BUT WP is not anymore! I'll update my requirements with 7.0 like WP.
We should add a warning on plugin's page, the thing is, how to say it?
"Warning: this plugin is not compatible with the minimum required PHP version 7.0, if you're running PHP 5.6 (data from plugin, could be less), you should upgrade your PHP version first"
I dunno :s

thanks for your opinions
ps: high prio because since 6.2.4 those plugins cannot be run on 5.6 anymore!

Change History (3)

#1 @Otto42
3 months ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to invalid
  • Status changed from new to closed

PHP requirements between core and plugins can be different, and that's ok. The PHP requirement is checked at the time of plugin installation.

#2 @Otto42
3 months ago

  • Keywords 2nd-opinion removed
  • Priority changed from high to normal

#3 @dd32
3 months ago

  • Component changed from General to Plugin Directory
Note: See TracTickets for help on using tickets.