Making WordPress.org

Opened 3 months ago

Closed 3 months ago

#7532 closed defect (bug) (reported-upstream)

WordPress embeds mistakenly load Chatrix JavaScript

Reported by: swissspidy's profile swissspidy Owned by:
Milestone: Priority: normal
Component: Communication (Matrix, Slack, IRC) Keywords:
Cc:

Description

If you embed a make/core post such as https://make.wordpress.org/core/2024/02/27/i18n-improvements-6-5-performant-translations/embed/ for example, they unnecessarily load the https://make.wordpress.org/core/wp-content/plugins/chatrix/build/logout.iife.js?ver=0.9.0 JS file.

That should not be loaded for embeds and causes console errors because the embed iframes are sandbox, so the JS can't access the document global variable anyway.

To reproduce:

  1. Visit https://make.wordpress.org/core/2024/02/27/i18n-improvements-6-5-performant-translations/embed/ in an incognito window
  2. See the JS file being loaded

Change History (2)

#1 @dd32
3 months ago

@swissspidy Would you be able to report this to the plugin team directly?

https://github.com/automattic/chatrix

#2 @swissspidy
3 months ago

  • Resolution set to reported-upstream
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.