Making WordPress.org

Opened 7 weeks ago

Closed 7 weeks ago

Last modified 7 weeks ago

#7572 closed defect (bug) (fixed)

No plugin/theme-specific support forum search form in new theme

Reported by: isemplice's profile isemplice Owned by: adamwood's profile adamwood
Milestone: Priority: high
Component: Support Forums Keywords:
Cc:

Description

On the new theme there is NOT the "SEARCH" field on the SUPPORT plugin's page! :-(

Only "Create Topic".

Change History (5)

#1 @coffee2code
7 weeks ago

  • Summary changed from NO "SEARCH" field on SUPPORT in the NEW THEME :-( to No plugin/theme-specific support forum search form in new theme

Confirmed. Just to clarify, there is a "Search forums" search form on each plugin/theme support forum, within a secondary navbar below the site navbar. This was also present in the old theme (but within the site navbar). This search form searches all support forums.

However, the old theme also had a "Search this forum" search field above the topic table (and next to the "Create Topic" button). This forum-specific search field would search just the topics from that plugin/theme. This second search field differed from the first by appending an "intext" search filter to what is ultimately a Google search (e.g. turning a forum search for error into error intext:"Plugin: Akismet Anti-spam: Spam Protection").

#2 @isemplice
7 weeks ago

Thank you for your answer!

I was implicitly referring myself to the <<"Search this forum" search field above the topic table (and next to the "Create Topic" button)>> because I was searching into the topicS of specific plugin.

From a UX point of view, I imagine many people less used to the platform as myself would have beel confused, because overnight the UI has changed and the Search field has disappeared.
Until few days ago (when WP must have changed the support page "theme") there were no problems with the so-called "old theme".

If WP keeps the changes has made on the support page "theme", I just hope would remain "Use the old theme" in order to search into the plugins support threat anyway.

#3 @adamwood
7 weeks ago

  • Owner set to adamwood
  • Status changed from new to assigned

Thanks for reporting, I'll get this reinstated.

#4 @adamwood
7 weeks ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 13501:

wporg-support-2024: Fix topic actions

Revert hiding the search this forum form, and update styles to match global search field
Style Create Topic button as primary

Fixes #7572
Fixes https://github.com/WordPress/wordpress.org/issues/245

#5 @adamwood
7 weeks ago

In 13503:

wporg-support-2024: Improve topic actions layout

See https://github.com/WordPress/wordpress.org/issues/245
See #7572

Note: See TracTickets for help on using tickets.