WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 23 months ago

#121 closed defect (fixed)

Support forum topics with Cyrillic titles cannot be found via Google

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Component: International Forums Keywords:
Cc:

Description

Migrating from #wp19011:

None of the topics with Cyrillic titles on ru.forums.wordpress.org can be found via Google. Topics with Latin slugs are indexed properly. Same for the other forums in Cyrillic (bg.forums.wordpress.org and sr.forums.wordpress.org).

This wasn't a big issue three years ago when there were just a few posts, but now that more and more questions are asked and answered each day, it's hard for users to find previous topics and solutions.

According to Otto, there's no robots.txt or anything else blocking Google from indexing them.

This is probably a Google bug, but I've tried to ask on their Help forum, and no one replied.

My guess is this has to do with 4th-level domains currently used for localized support forums. In this case, wouldn't it be possible to switch from ru.forums.wordpress.org to ru.wordpress.org/support/, similarly to English support forums?

Another workaround would be to switch again to numeric permalinks (provided that the current links will remain accessible). Seems like it's possible at least in bbPress 1.1.

Change History (10)

#1 @SergeyBiryukov
4 years ago

  • Priority changed from low to normal

Could be related to #245?

#2 @SergeyBiryukov
4 years ago

To clarify:

  • There's no way to get localized search results using the "Search WordPress.org" form in the header (#347).
  • There's no way to find them via Google either (this ticket).
  • "Search term" in bbPress admin doesn't work for Cyrillic words (#276).

So even if I do remember the keywords of a specific topic, it's still virtually impossible to find it.

Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#3 follow-up: @joostdevalk
3 years ago

Do you have examples of URLs that you can't find in Google? Or am I misunderstanding what your meaning with this issue is? :)

#4 @joostdevalk
3 years ago

  • Cc joost@… added

#6 @joostdevalk
3 years ago

I think the issue is caused because we do a 302 redirect from the URL to the url encoded version of the URL:

curl -i https://ru.forums.wordpress.org/topic/логин-не-может-содержать-символ-__
HTTP/1.1 302 Found
Server: nginx
Date: Sun, 28 Jun 2015 14:00:37 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Location: https://ru.forums.wordpress.org/topic/%d0%bb%d0%be%d0%b3%d0%b8%d0%bd-%d0%bd%d0%b5-%d0%bc%d0%be%d0%b6%d0%b5%d1%82-%d1%81%d0%be%d0%b4%d0%b5%d1%80%d0%b6%d0%b0%d1%82%d1%8c-%d1%81%d0%b8%d0%bc%d0%b2%d0%be%d0%bb-_
X-Frame-Options: SAMEORIGIN
X-nc: MISS lax 250

Removing that redirect (as it's completely unneeded from a technical perspective) would fix it, but it might be easier to "just" switch to a newer version of bbPress ;)

This ticket was mentioned in Slack in #meta by ocean90. View the logs.


2 years ago

#8 @samuelsidler
2 years ago

Tracking bug for upgrading to bbPress 2.x is #1544.

This ticket was mentioned in Slack in #meta-tracdev by sergey. View the logs.


23 months ago

#10 @SergeyBiryukov
23 months ago

  • Resolution set to fixed
  • Status changed from new to closed

After the upgrade to bbPress 2.x in #1544, topics with Cyrillic slugs finally started appearing in Google results.

Note: See TracTickets for help on using tickets.