WordPress.org

Making WordPress.org

#1544 closed task (fixed)

Upgrade international forums from bbPress.old to bbPress 2.x

Reported by: samuelsidler Owned by:
Milestone: Priority: high
Component: International Forums Keywords:
Cc:

Description

This is our master ticket for upgrading the international forums to bbPress 2.x.

Attachments (7)

meta-1544.translator-comments.patch (2.8 KB) - added by SergeyBiryukov 17 months ago.
meta-1544.translator-comments.2.patch (2.8 KB) - added by SergeyBiryukov 17 months ago.
meta-1544.list-style.patch (704 bytes) - added by SergeyBiryukov 17 months ago.
Bildschirmfoto 2016-08-01 um 18.08.03.png (56.8 KB) - added by zodiac1978 17 months ago.
Before
Bildschirmfoto 2016-08-01 um 18.10.38.png (51.1 KB) - added by zodiac1978 17 months ago.
After
meta-1544.error-strings.patch (2.7 KB) - added by SergeyBiryukov 16 months ago.
oembed_error.png (333.1 KB) - added by hideokamoto 16 months ago.

Download all attachments as: .zip

Change History (77)

#1 @jmdodd
18 months ago

In 3612:

Support: bbPress Version Dropdown initial folder commit.

See #1544.

#2 @jmdodd
18 months ago

In 3613:

Support: bbPress Version Dropdown initial commit.

See #1544.

#3 @jmdodd
18 months ago

In 3614:

Support: Prefix the version filter to avoid potential confusion.

See #1544.

#4 @jmdodd
18 months ago

In 3615:

Support: Add WordPress versions to dropdown.

See #1544.

#5 @jmdodd
18 months ago

In 3616:

Forums Theme: Add WordPress version to topic sidebar.

See #1544.

#6 @jmdodd
17 months ago

In 3652:

Support: Codexify initial commit.

See #1544.

#7 @jmdodd
17 months ago

In 3653:

Support: Use WordPress-native functions to improve escaping.

See #1544.

#8 @jmdodd
17 months ago

In 3703:

Support: Change the topic title when it is resolved in Topic Resolution plugin.

See #1544.

#9 @jmdodd
17 months ago

In 3704:

Support: Clear up some PHP strict notices in Version Dropdown.

See #1544.

#10 @jmdodd
17 months ago

In 3718:

Support: Term Subscription initial folder commit.

See #1544.

#11 @jmdodd
17 months ago

In 3719:

Support: Term Subscription initial commit.

See #1544.

#12 @ocean90
17 months ago

In 3737:

Support, Version Dropdown: Clean up HTML for dropdown.

  • Use correct value for the for attribute of the label.
  • Print description before dropdown.
  • Replace echo esc_html( __( ) ) with esc_html_e().

See #1544.

#13 @ocean90
17 months ago

In 3738:

Support, Topic Resolution: Add missing text domain and use esc_html_e().

Also use the correct value for the for attribute of the labels.

See #1544.

#14 @ocean90
17 months ago

In 3739:

Support: Use wporg-forums as the text domain for bbPress plugins.

We already use it for the theme.

See #1544.

This ticket was mentioned in Slack in #meta by ocean90. View the logs.


17 months ago

#16 follow-up: @petya
17 months ago

A couple of suggestions for changes/translator comments for some of the strings:

Term subscription error messages:

Suggestion: Add translator comment: Term: topic tag

#18 in reply to: ↑ 16 @SergeyBiryukov
17 months ago

Replying to petya:

This topic is - https://translate.wordpress.org/projects/meta/forums/bg/default?filters[original_id]=3151369 - remove the verb from the string or change to Topic status. That would prevent issues with languages where the verb has a different place within the sentence structure - for example at the end of the sentence.

On second thought, Topic status is not really accurate for "not a support question". May be This topic is: would work? You can move the verb from this string to the dropdown options if needed. In Russian, we don't have a verb in this dropdown at all :)

#19 @SergeyBiryukov
17 months ago

You are receiving this email because you subscribed to a topic tag.

Is there a way to add the tag name to this string to make it clearer?

#20 @jmdodd
17 months ago

In 3746:

Support: Improve label for translations in Topic Resolution plugin.

See #1544.

#21 @jmdodd
17 months ago

In 3747:

Support: Add translator comments to Term Subscription plugin.

Props @SergeyBiryukov.

See #1544.

#22 @jmdodd
17 months ago

In 3748:

Support: Add translator comments to Version Dropdown plugin.

Props @SergeyBiryukov.

See #1544.

#23 follow-up: @pixolin
17 months ago

I found some error in the styling of ordered lists (<ol>…</ol>):

File https://bbpress.org/wp-content/themes/bb-base/style.css line 1105 contains following CSS rule

#bbpress-forums li.bbp-body div.bbp-topic-content li,
#bbpress-forums li.bbp-body div.bbp-reply-content li {
	list-style: square;
	margin-left: 10px;
}

which causes all list items to be prepended with a square instead of decimals.
(Example: Post https://de.wordpress.org/support/topic/mehrere-websites-mit-mamp/#post-29566)

Last edited 17 months ago by pixolin (previous) (diff)

#24 @SergeyBiryukov
17 months ago

Some topic URLs with UTF-8 slugs on non-Latin forums (e.g. Russian or Japanese) are currently broken, see #1867.

#25 @SergeyBiryukov
17 months ago

meta-1544.list-style.patch should fix the list style issue from comment:23.

#26 follow-ups: @SergeyBiryukov
17 months ago

#27 in reply to: ↑ 26 @zodiac1978
17 months ago

Replying to SergeyBiryukov:

I asked that in Slack and @jmdodd answered

I need to copy over WordPress roles from the parent language blog.

https://wordpress.slack.com/archives/forums/p1469786174002586

#28 in reply to: ↑ 26 @ocean90
17 months ago

Replying to SergeyBiryukov:

You should have access now. Roles are currently WIP but should be fixed soon.

#29 in reply to: ↑ 23 @netweb
17 months ago

Replying to pixolin:

I found some error in the styling of ordered lists (<ol>…</ol>):

File https://bbpress.org/wp-content/themes/bb-base/style.css line 1105 contains following CSS rule

#bbpress-forums li.bbp-body div.bbp-topic-content li,
#bbpress-forums li.bbp-body div.bbp-reply-content li {
	list-style: square;
	margin-left: 10px;
}

which causes all list items to be prepended with a square instead of decimals.
(Example: Post https://de.wordpress.org/support/topic/mehrere-websites-mit-mamp/#post-29566)

Related: #BuddyPress5961

#30 @netweb
17 months ago

In 3755:

BuddyPress.org: Only style unordered lists list items with list-style: square;

Previously all list items were styled using list-style: square; causing ordered lists to not be styled as expected.

Props @SergeyBiryukov.
See #1544, Fixes #BuddyPress5961

#31 follow-up: @SergeyBiryukov
17 months ago

Could we change the site title on https://ru.wordpress.org/support/ back to "Форумы поддержки"?

"Русский Support Forums" is neither Russian nor English, and this incorrect title is already indexed by Google.

Last edited 17 months ago by SergeyBiryukov (previous) (diff)

#32 in reply to: ↑ 31 ; follow-up: @netweb
17 months ago

Replying to SergeyBiryukov:

Could we change the site title on https://ru.wordpress.org/support/ back to "Форумы поддержки"?

"Русский Support Forums" is neither Russian nor English, and this incorrect title is already indexed by Google.

The same for all the converted forums by the looks of things:

  • Japanese: 日本語 Support Forums
  • Portuguese: Português Support Forums
  • etc...

#33 in reply to: ↑ 32 ; follow-up: @pixolin
17 months ago

Replying to netweb:

The same for all the converted forums by the looks of things:

  • Japanese: 日本語 Support Forums
  • Portuguese: Português Support Forums
  • etc...

Would it make sense to change the order?

  • Support Forums: 日本語
  • Support Forums: Português
  • Support Forums: Deutsch
  • etc…

(Deutsch Support Forum also is bad grammar, Deutsches Support Forum would be OK, also Support Forum: Deutsch)

Last edited 17 months ago by pixolin (previous) (diff)

#34 follow-up: @pixolin
17 months ago

It seems we currently have no way to mark threads as resolved?
(neither in the admin links underneath posts, nor in the admin sidebar and also not in the backend)

#35 in reply to: ↑ 34 ; follow-up: @ocean90
17 months ago

Replying to pixolin:

It seems we currently have no way to mark threads as resolved?
(neither in the admin links underneath posts, nor in the admin sidebar and also not in the backend)

Click Edit on the first post in a topic and there you should see a select box below the title field.

#36 follow-up: @fierevere
17 months ago

we cant anymore see poster IP and filter posts/comments by source IP ?

#37 in reply to: ↑ 33 ; follow-up: @netweb
17 months ago

Replying to pixolin:

Replying to netweb:

The same for all the converted forums by the looks of things:

  • Japanese: 日本語 Support Forums
  • Portuguese: Português Support Forums
  • etc...

Would it make sense to change the order?

  • Support Forums: 日本語
  • Support Forums: Português
  • Support Forums: Deutsch
  • etc…

(Deutsch Support Forum also is bad grammar, Deutsches Support Forum would be OK, also Support Forum: Deutsch)

I think it should be "Support Forums" in the language of the site locale, e.g. "Форумы поддержки", no need to add the locale name as it's already included in the Rosetta sites banner, e.g "Русский" at https://ru.wordpress.org/support/

#38 in reply to: ↑ 36 @netweb
17 months ago

Replying to fierevere:

we cant anymore see poster IP and filter posts/comments by source IP ?

Currently only bbPress "keymasters" (admins) can view user IP addresses. There is a proposed plugin to add this functionality, it will be either added to bbPress core, or added as a plugin for wp.org. See #bb2908

Edit: Currently only "keymasters" (admins) can see IP addresses on the "front end", moderators can see IP addresses in the "back end", thanks and hat tip @ocean90 for reminding me of that

Last edited 17 months ago by netweb (previous) (diff)

#39 in reply to: ↑ 37 @SergeyBiryukov
17 months ago

Replying to netweb:

I think it should be "Support Forums" in the language of the site locale, e.g. "Форумы поддержки", no need to add the locale name as it's already included in the Rosetta sites banner, e.g "Русский" at https://ru.wordpress.org/support/

Right, locale name in the title would be redundant. On https://wordpress.org/support/, for example, the title is not "English Support Forums", just "Support"

#40 follow-up: @zodiac1978
17 months ago

Is there a reason why the forums column on the homepage is just 60% width?

#bbpress-forums li.bbp-forum-info {
    width: 60%;
}

In: https://de.wordpress.org/support/wp-content/themes/pub/wporg-forums/style.css?ver=20160701

Because the other column is just 20% which sums up to 80% and not 100%

#bbpress-forums li.bbp-forum-topic-count, #bbpress-forums li.bbp-forum-reply-count {
    width: 20%;
}

Looks fine if I change the first class to 80% width.

Last edited 17 months ago by zodiac1978 (previous) (diff)

#41 follow-up: @zodiac1978
17 months ago

Looking at the screenshot I see another glitch:
20,247 should be 20.247 for German.

Seems to be not using number_format_i18n

#42 in reply to: ↑ 41 @ocean90
17 months ago

Replying to zodiac1978:

Looking at the screenshot I see another glitch:
20,247 should be 20.247 for German.

Seems to be not using number_format_i18n

See #1882.

#43 @zodiac1978
17 months ago

bbpress is graying out closed posts, which is good.

If you make a post sticky or super-sticky you want to highlight those posts, but they are grayed out as well, which is bad.

#bbpress-forums ul.status-closed, #bbpress-forums ul.status-closed a {
    color: #ccc;
}

In https://de.wordpress.org/support/wp-content/plugins/bbpress/templates/default/css/bbpress.min.css?ver=2.6-alpha-5566
and
https://bbpress.org/wp-content/themes/bb-base/style.css?ver=20150216d

Maybe overriding with something like:

#bbpress-forums ul.sticky a.bbp-topic-permalink, 
#bbpress-forums ul.super-sticky a.bbp-topic-permalink {
    color: #21759b;
}

and

#bbpress-forums ul.sticky li.bbp-topic-title a.bbp-topic-permalink::before, 
#bbpress-forums ul.super-sticky li.bbp-topic-title a.bbp-topic-permalink::before {
    color: #ffb900 !important;
}

Maybe there is a smarter way to do that ... :)

#44 in reply to: ↑ 40 @netweb
17 months ago

Replying to zodiac1978:

Is there a reason why the forums column on the homepage is just 60% width?

#bbpress-forums li.bbp-forum-info {
    width: 60%;
}

In: https://de.wordpress.org/support/wp-content/themes/pub/wporg-forums/style.css?ver=20160701

Because the other column is just 20% which sums up to 80% and not 100%

#bbpress-forums li.bbp-forum-topic-count, #bbpress-forums li.bbp-forum-reply-count {
    width: 20%;
}

Looks fine if I change the first class to 80% width.

The "Topic Count" columin is the 20% that is missing there, working on a patch now that brings it back to:
https://cldup.com/thCidsA_CD.png

This ticket was mentioned in Slack in #meta by lageek. View the logs.


17 months ago

#46 @La Geek
17 months ago

  • Priority changed from high to normal

I (very much) apologize, I guess, I wrote this ticket #1887 in the wrong place.

It is a bug or enhancement ticket for "Upgrade international forums from bbPress.old to bbPress 2.x"

Beside this bug in the ticket above, I found one more glitch:

The tags cloud https://de.wordpress.org/support/view/all-topics/. Please look at "Fehlermeldung". The tags overflow the wrapping div. And would collidate with, resp. overlap the right column - luckily there is no content atm.

A tag example:

<a style="font-size: 28.519230769231pt;" title="79 Themen" class="tag-link-167 tag-link-position-25" href="https://de.wordpress.org/support/topic-tag/fehlermeldung/">Fehlermeldung</a>
Last edited 17 months ago by SergeyBiryukov (previous) (diff)

This ticket was mentioned in Slack in #polyglots by yui. View the logs.


17 months ago

#48 in reply to: ↑ description @vitormadeira
17 months ago

  • Keywords ux-feedback ui-feedback added
  • Summary changed from Upgrade international forums from bbPress.old to bbPress 2.x to Text fonts too small on international forums on bbPress 2.x
  • Type changed from task to defect

Replying to samuelsidler:

This is our master ticket for upgrading the international forums to bbPress 2.x.

I'm browsing on a Samsung S3 smartphone with Google Chrome and Opera Mini browsers and the text size on the support forums (www.wordpress.org.pt/support) appears a bit too small.

Also, some elements are not correctly displayed. Some text elements appear on top of others as well as users avatar images.

#49 follow-up: @ocean90
17 months ago

  • Keywords ux-feedback ui-feedback removed
  • Priority changed from normal to high
  • Summary changed from Text fonts too small on international forums on bbPress 2.x to Upgrade international forums from bbPress.old to bbPress 2.x
  • Type changed from defect to task

@vitormadeira For mobile issues see #1138.

#50 in reply to: ↑ 49 @vitormadeira
17 months ago

Replying to ocean90:

@vitormadeira For mobile issues see #1138.

Thank you.

#51 in reply to: ↑ 35 @La Geek
17 months ago

Replying to ocean90:

Replying to pixolin:

It seems we currently have no way to mark threads as resolved?
(neither in the admin links underneath posts, nor in the admin sidebar and also not in the backend)

Click Edit on the first post in a topic and there you should see a select box below the title field.

This means on the other side, that users themselves can't mark their threads as resolved anymore. Since the time to edit own posts is limited.

#52 follow-up: @DeFries
17 months ago

My role isn't reflected in the Topic Author section. Example can be found here: https://nl.wordpress.org/support/topic/kom-je-spam-tegen-5/. It should say Key Master (or the Dutch translation of that), but it says Contributor (Bijdrager in Dutch).

#53 in reply to: ↑ 52 ; follow-up: @pixolin
17 months ago

Replying to DeFries:

My role isn't reflected in the Topic Author section. Example can be found here: https://nl.wordpress.org/support/topic/kom-je-spam-tegen-5/. It should say Key Master (or the Dutch translation of that), but it says Contributor (Bijdrager in Dutch).

Isn't "Sleutelbeheerder" the Dutch word for Keymaster? At least that's what I see underneath your Gravatar, when I open the link.

#54 in reply to: ↑ 53 ; follow-up: @DeFries
17 months ago

Replying to pixolin:

Replying to DeFries:

My role isn't reflected in the Topic Author section. Example can be found here: https://nl.wordpress.org/support/topic/kom-je-spam-tegen-5/. It should say Key Master (or the Dutch translation of that), but it says Contributor (Bijdrager in Dutch).

Isn't "Sleutelbeheerder" the Dutch word for Keymaster? At least that's what I see underneath your Gravatar, when I open the link.

It is, yes. I must have triggered something by replying to a topic. Love it when issues solve themselves :P

Does anyone know if it is safe to edit the bbPress slug settings? Converting those English words into Dutch words.

#55 in reply to: ↑ description ; follow-up: @W.P. Ginfo
17 months ago

Replying to samuelsidler:

This is our master ticket for upgrading the international forums to bbPress 2.x.

I noticed the layout etc of the forum has been updated. It now looks nice and fresh.

I also bumped into a serious practical problem:

Over the years I have tried to answer questions in both
<ul><li>the international forum, -some time ago- and</li>
<li>the dutch forum 'https://nl.wordpress.org/support/' -still active, almost on a daily basis-</li>
</ul>
When I now log in to the DUTCH forum to check my Profile to see if any of the forum members have responded to my suggestions, all I see is a list of the <em>international</em> entries I made.

So far, I've been unable to find a listing my entries / activities on the DUTCH forum.
Please advise how to solve this.

Kind regards

W.P. Ginfo

Last edited 17 months ago by W.P. Ginfo (previous) (diff)

#56 in reply to: ↑ 54 @netweb
17 months ago

Replying to DeFries:

Does anyone know if it is safe to edit the bbPress slug settings? Converting those English words into Dutch words.

I'd say no, for now, you will break any URL redirects in place, I'd suggest a new ticket for this.

#57 in reply to: ↑ 55 @netweb
17 months ago

Replying to W.P. Ginfo:

Replying to samuelsidler:

This is our master ticket for upgrading the international forums to bbPress 2.x.

I noticed the layout etc of the forum has been updated. It now looks nice and fresh.

I also bumped into a serious practical problem:

Over the years I have tried to answer questions in both
<ul><li>the international forum, -some time ago- and</li>
<li>the dutch forum 'https://nl.wordpress.org/support/' -still active, almost on a daily basis-</li>
</ul>
When I now log in to the DUTCH forum to check my Profile to see if any of the forum members have responded to my suggestions, all I see is a list of the <em>international</em> entries I made.

So far, I've been unable to find a listing my entries / activities on the DUTCH forum.
Please advise how to solve this.

Kind regards

W.P. Ginfo

This is being tracked in #1868

#58 @jmdodd
16 months ago

In 3783:

Support: Add yes/no/mu views to Topic Resolution.

See #1544, #1873.

#59 @jmdodd
16 months ago

In 3797:

Support: Allow front-end updating of topic resolution.

Lets moderators and topic authors change the topic resolution status.

See #1544, #1873.

#60 @jmdodd
16 months ago

In 3798:

Forums Theme: Add editable topic resolution to single topic pages.

See #1544, #1873.

#61 @SergeyBiryukov
16 months ago

meta-1544.error-strings.patch fixes a missing apostrophe in a string added in [3797] (You don\t have permission) and makes two other similar strings use alternate quotes instead of unnecessary escaping, as suggested in the WP coding standards.

#62 follow-up: @hideokamoto
16 months ago

Forum works oEmbed.
But many website still using http.
So some topic happend Mixed Content Error.

# User written...

http://blog.showzine.co/entry/hide_others-posts

# Happend Error message

Mixed Content: The page at 'https://ja.wordpress.org/support/topic/%e7%ae%a1%e7%90%86%e7%94%bb%e9%9d%a2…7%e3%81%9f%e3%82%82%e3%81%ae%e3%81%a0%e3%81%91%e3%82%92%e8%a1%a8%e7%a4%ba/' was loaded over HTTPS, but requested an insecure resource 'http://blog.showzine.co/embed/hide_others-posts'. This request has been blocked; the content must be served over HTTPS.

# ScreenShot
https://meta.trac.wordpress.org/raw-attachment/ticket/1544/oembed_error.png

Could you disabled oEmbed?

#63 in reply to: ↑ 62 ; follow-up: @netweb
16 months ago

Replying to hideokamoto:

Forum works oEmbed.
But many website still using http.
So some topic happend Mixed Content Error.

# User written...

http://blog.showzine.co/entry/hide_others-posts

# Happend Error message

Mixed Content: The page at 'https://ja.wordpress.org/support/topic/%e7%ae%a1%e7%90%86%e7%94%bb%e9%9d%a2…7%e3%81%9f%e3%82%82%e3%81%ae%e3%81%a0%e3%81%91%e3%82%92%e8%a1%a8%e7%a4%ba/' was loaded over HTTPS, but requested an insecure resource 'http://blog.showzine.co/embed/hide_others-posts'. This request has been blocked; the content must be served over HTTPS.

Could you disabled oEmbed?

I spoke with @peterwilsoncc yesterday about this exact post, there was a filter added, then reverted in #WP34588 to to disable non-SSL embeds on SSL sites, maybe someone has an alternate approach to @pento's in #WP34588?

#64 in reply to: ↑ 63 ; follow-up: @tenpura
16 months ago

Replying to netweb:

I spoke with @peterwilsoncc yesterday about this exact post, there was a filter added, then reverted in #WP34588 to to disable non-SSL embeds on SSL sites, maybe someone has an alternate approach to @pento's in #WP34588?

We don't need Auto-embed functionality in the Japanese forums so it's ok to turn it off completely. I think it can be done by simply unchecking the "Auto-embed links" option in the Forum Features settings.

#65 @jmdodd
16 months ago

In 3845:

Support: Support Forums initial folder commit.

See #1544.

#66 @jmdodd
16 months ago

In 3846:

Support: Support Forums initial commit.

See #1544.

This ticket was mentioned in Slack in #bbpress by netweb. View the logs.


16 months ago

#68 @coffee2code
15 months ago

In 3978:

Support: User Badges initial commit.

Adds badges to user replies. Currently assigns one of three potential badges:

  • Plugin Author : replies made in the support/review forum for a plugin the reply author has commit access to
  • Plugin Contributor : replies made in the support/review forum for a plugin the reply author is listed as a contributor
  • Theme Author : replies made in the support/review forum for a theme the reply author has commit access to

See #1544.
Fixes #1993.

#69 in reply to: ↑ 64 @SergeyBiryukov
15 months ago

Replying to tenpura:

We don't need Auto-embed functionality in the Japanese forums so it's ok to turn it off completely. I think it can be done by simply unchecking the "Auto-embed links" option in the Forum Features settings.

Related: #2097

#70 @ocean90
10 months ago

  • Resolution set to fixed
  • Status changed from new to closed

I guess we can close this one as fixed.

Note: See TracTickets for help on using tickets.