WordPress.org

Making WordPress.org

Opened 18 months ago

Closed 17 months ago

Last modified 17 months ago

#1868 closed enhancement (fixed)

Forums should have a way to view a particular user's posts

Reported by: SergeyBiryukov Owned by: jmdodd
Milestone: Priority: high
Component: Support Forums Keywords: has-patch commit
Cc:

Description (last modified by SergeyBiryukov)

On the new bbPress 2.x forums, there's no way to view all my (or someone else's) posts.

Previously, I could see them on https://ru.forums.wordpress.org/profile/sergeybiryukov, which now redirects to https://ru.wordpress.org/support/profile/sergeybiryukov and produces a "Page not found" error.

The correct URL appears to be https://ru.wordpress.org/support/users/sergeybiryukov/replies, but both the left navigation menu and pagination links are broken there.

All profile links in the forum templates just link to https://profiles.wordpress.org/sergeybiryukov, which is not helpful, because it does not include international forums activity (see #129).

Attachments (1)

1868-redirect.diff (807 bytes) - added by netweb 18 months ago.

Download all attachments as: .zip

Change History (36)

#2 follow-ups: @SergeyBiryukov
18 months ago

@netweb: Thanks! We should add https://ru.wordpress.org/support/users/sergeybiryukov/ to the templates then instead of the WP.org profile.

On https://ru.wordpress.org/support/users/sergeybiryukov/replies, both the left navigation menu and pagination links are broken, they lead to the WP.org profile:

#3 in reply to: ↑ 2 @SergeyBiryukov
18 months ago

Replying to SergeyBiryukov:

On https://ru.wordpress.org/support/users/sergeybiryukov/replies, both the left navigation menu and pagination links are broken

Created a separate ticket for that: #1871

#4 in reply to: ↑ 2 @netweb
18 months ago

Replying to SergeyBiryukov:

@netweb: Thanks! We should add https://ru.wordpress.org/support/users/sergeybiryukov/ to the templates then instead of the WP.org profile.

The end goal has always been to use the WP.org profiles, though the extra functionality to facilitate the previous URLs mentioned still need to be added to profiles.wordpress.org.

On https://ru.wordpress.org/support/users/sergeybiryukov/replies, both the left navigation menu and pagination links are broken, they lead to the WP.org profile:

Because we're redirecting user profiles to profiles.wordpress.org via `wporg_support_profile_url`

#5 @ocean90
18 months ago

#1871 was marked as a duplicate.

#6 @ocean90
18 months ago

  • Type changed from defect to enhancement

netweb:

The end goal has always been to use the WP.org profiles, though the extra functionality to facilitate the previous URLs mentioned still need to be added to profiles.wordpress.org.

That's exactly what we're aiming for.

#7 @SergeyBiryukov
18 months ago

I'm all for improving WP.org profiles, but it won't happen this year, will it? In the meantime, forum profiles should have this basic functionality.

#8 @netweb
18 months ago

  • Keywords close added

This ticket can probable be closed as a duplicate of #129: Profile pages should include activity on local forums as well

The redirection and unified profiles discussion above should happen in ticket #518: unify profiles

#9 follow-up: @SergeyBiryukov
18 months ago

  • Keywords close removed

#129 and #518 are enhancements for (still not open sourced) WP.org profiles.

This ticket is a regression on local forums.

Last edited 18 months ago by SergeyBiryukov (previous) (diff)

#10 in reply to: ↑ 9 ; follow-ups: @samuelsidler
18 months ago

Replying to SergeyBiryukov:

#129 and #518 are enhancements for (still not open sourced) WP.org profiles.

This ticket is a regression on local forums.

Regardless, I think #129 is the right way to fix this ticket. Having two separate profiles isn't helpful long-term.

#11 in reply to: ↑ 10 @netweb
18 months ago

Thinking on this some more, by temporarily removing the redirect to profiles.wordpress.org:

  • Give the international forum users said "basic functionality" now comment:7
  • I've already listed workaround URLs for this in comment:1
  • profiles.wordpress.org is yet to be open sourced
  • It's a minor code change with significant UX imporovements

#12 @netweb
18 months ago

In 1868-redirect.diff should suffice until profile integration with profiles.wordpress.org progresses.

#13 in reply to: ↑ 10 @SergeyBiryukov
18 months ago

Replying to samuelsidler:

Regardless, I think #129 is the right way to fix this ticket. Having two separate profiles isn't helpful long-term.

I agree about long term, but I think English support team wouldn't be happy either if /support/profile/{username} pages were gone right now, and there was no forum activity whatsoever on WP.org profiles, which is the case for us.

To summarize, three things I'd like to see here:

  • In content-single-topic-lead.php, link either username or role to /support/users/{username}/.
  • Fix navigation on that page using 1868-redirect.diff.
  • Redirect https://ru.forums.wordpress.org/profile/{username} to /support/users/{username}/.

(Some of our active contributors used to link to their forum profile from other sites, I don't see a reason to break that URL if we can redirect it to the correct place.)

#14 follow-up: @SergeyBiryukov
18 months ago

Admins and moderators can figure out the workaround URLs, but regular users are pretty confused when they can't find their own topics.

#15 in reply to: ↑ 14 ; follow-up: @W.P. Ginfo
18 months ago

Replying to SergeyBiryukov:

Admins and moderators can figure out the workaround URLs, but regular users are pretty confused when they can't find their own topics.

You are quite right!!
I'm a contributor to both the international and the dutch forum.
Unfortunately I can see only the international topics and not the ones in the dutch forum.
Although it's suggested that the solution is somewhere in this ticket, I have not a clue what to do to get things working again...

This used to work: https:

#16 @SergeyBiryukov
18 months ago

  • Description modified (diff)
  • Priority changed from normal to high

#17 in reply to: ↑ 15 @gblsm
17 months ago

Replying to W.P. Ginfo:

I'm a contributor to both the international and the dutch forum.
Unfortunately I can see only the international topics and not the ones in the dutch forum.
Although it's suggested that the solution is somewhere in this ticket, I have not a clue what to do to get things working again...

It’s same for me, a contributer to the Japanese forum.
I am looking forward to seeing the list of my previous posts/comments again soon.

#18 follow-up: @netweb
17 months ago

FYI: The Dutch forums user profile slug appears to have changed from users to user

bbPress' default user slug is users:

  • Works: https://nl.wordpress.org/support/user/wp-ginfo/topics
  • Broken: https://nl.wordpress.org/support/users/wp-ginfo/topics

Via https://nl.wordpress.org/support/topic/veranderd-forum-mooi-maar-verdwaald/#post-99158

#19 in reply to: ↑ 18 @tenpura
17 months ago

Replying to netweb:

FYI: The Dutch forums user profile slug appears to have changed from users to user

bbPress' default user slug is users:

  • Works: https://nl.wordpress.org/support/user/wp-ginfo/topics
  • Broken: https://nl.wordpress.org/support/users/wp-ginfo/topics

Via https://nl.wordpress.org/support/topic/veranderd-forum-mooi-maar-verdwaald/#post-99158

You are right. Now all of these links are working.

https://ja.wordpress.org/support/user/tenpura/
https://ja.wordpress.org/support/user/tenpura/topics/
https://ja.wordpress.org/support/user/tenpura/replies/
https://ja.wordpress.org/support/user/tenpura/favorites/
https://ja.wordpress.org/support/user/tenpura/subscriptions/
https://ja.wordpress.org/support/user/tenpura/edit/

Questions:

  1. How do I reflect these to the actual links in the sidebar?
  2. Which is the desirable user profile slug: "user" or "users"?
Last edited 17 months ago by tenpura (previous) (diff)

#20 follow-ups: @ocean90
17 months ago

Not sure why this happens but that's what I've found out:

#21 in reply to: ↑ 20 ; follow-up: @netweb
17 months ago

Replying to ocean90:

Not sure why this happens but that's what I've found out:

Great catch on the user/users slug, thanks, will investigate further and write some tests and fix bbPress side

It looks like maybe none of bbPress options are in the wp_options table for the Dutch and Japanese sites

I expect the correct option values will be there for the Russian site, but empty for Dutch and Japanese:

  • Returns empty: wp --url=ja.wordpress.org/support/ option get _bbp_user_favs_slug
  • Returns empty: wp --url=nl.wordpress.org/support/ option get _bbp_user_favs_slug
  • Returns favorites: wp --url=ru.wordpress.org/support/ option get _bbp_user_favs_slug

Similar for _bbp_user_slug, though Dutch and Japanese will pickup that default user value

  • Returns user: wp --url=ja.wordpress.org/support/ option get _bbp_user_slug
  • Returns user: wp --url=nl.wordpress.org/support/ option get _bbp_user_slug
  • Returns users: wp --url=ru.wordpress.org/support/ option get _bbp_user_slug

Are there any bbPress options at all in wp_options for Dutch and Japanese forum sites? (bbPress uses _bbp prefix)

#22 in reply to: ↑ 21 ; follow-up: @jmdodd
17 months ago

Replying to netweb:

Are there any bbPress options at all in wp_options for Dutch and Japanese forum sites? (bbPress uses _bbp prefix)

I've resaved the bbPress options for all Rosetta sites to force an update; some of the sites did not get the options updated to their default values during the installation. This should resolve the user/users issue on the forums.

#23 @cristiano.zanca
17 months ago

In our Italian forum this is the url working

https://it.wordpress.org/forums/users/cristianozanca/replies

there must be a redirect from /forums ->> to /support and it has to be fixed with the other links but works!

Jennifer already knows about it, only to share the working url with you

Last edited 17 months ago by cristiano.zanca (previous) (diff)

#24 in reply to: ↑ 22 ; follow-up: @netweb
17 months ago

Replying to jmdodd:

I've resaved the bbPress options for all Rosetta sites to force an update; some of the sites did not get the options updated to their default values during the installation. This should resolve the user/users issue on the forums.

Any idea why this happened? It's not a good experience if bbPress has a bug that prevents its options being saved when activated, I'd like to get to the bottom of this and get it fixed if it's a bbPress problem.

@jmdodd To that end, are the wp-cli script or scripts that have been being used available to me so I can test these please?

#25 in reply to: ↑ 24 ; follow-up: @jmdodd
17 months ago

Replying to netweb:

@jmdodd To that end, are the wp-cli script or scripts that have been being used available to me so I can test these please?

I ran activate_plugin( 'bbpress/bbpress.php' ); on the wpmu_new_blog action.

#26 in reply to: ↑ 25 @netweb
17 months ago

Replying to jmdodd:

Replying to netweb:

@jmdodd To that end, are the wp-cli script or scripts that have been being used available to me so I can test these please?

I ran activate_plugin( 'bbpress/bbpress.php' ); on the wpmu_new_blog action.

That sounds fine, but still doesn't help debug the issue, the creation script you mention here, does that have anything else in it that might cause the options to be wiped after activation? Can that script and any others used be made available to the bbPress team or open sourced?

#27 in reply to: ↑ 20 @netweb
17 months ago

Replying to ocean90:

Not sure why this happens but that's what I've found out:

Fixed in bbPress:changeset:6078 / #bbPress2983

#28 in reply to: ↑ 10 @SergeyBiryukov
17 months ago

Replying to samuelsidler:

Regardless, I think #129 is the right way to fix this ticket. Having two separate profiles isn't helpful long-term.

#129 is now fixed (see #1953 though), but it's still not a viable solution:

  • The Activity page only displays the latest replies, there's no access to all topics and replies.
  • Forum profiles should have UI in the forum language, whereas WP.org profiles are intentionally English-only. Merging them would require some kind of i18n roadmap for WP.org profiles.

#29 @keesiemeijer
17 months ago

If we're not redirecting we should get the pagination and left sidebar links updated to go to right pages.

#30 @ocean90
17 months ago

  • Component changed from International Forums to Support Forums

#31 @SergeyBiryukov
17 months ago

  • Keywords has-patch commit added

Marking 1868-redirect.diff for commit.

#32 in reply to: ↑ 2 @SergeyBiryukov
17 months ago

Replying to SergeyBiryukov:

On https://ru.wordpress.org/support/users/sergeybiryukov/replies, both the left navigation menu and pagination links are broken, they lead to the WP.org profile

Just noticed that Unsubscribe links on https://ru.wordpress.org/support/users/sergeybiryukov/subscriptions/ are broken as well, for the same reason.

#33 @jmdodd
17 months ago

  • Owner set to jmdodd
  • Resolution set to fixed
  • Status changed from new to closed

In 3973:

Forums Theme: Use bbPress 2 user profiles on the forums.

Users on Rosetta and support forums need to be able to manage their subscriptions/favorites/etc.

Until there is a unified user profile that covers these needs, we should use the forum-specific profiles.

Props SergeyBiryukov, netweb.

Fixes #1868.

This ticket was mentioned in Slack in #forums by cristiano.zanca. View the logs.


17 months ago

This ticket was mentioned in Slack in #forums by keesiemeijer. View the logs.


17 months ago

Note: See TracTickets for help on using tickets.