WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1272 closed defect (fixed)

Theme Directory - theme action btns

Reported by: ramiy Owned by: ocean90
Milestone: Priority: normal
Component: Theme Directory Keywords: has-patch
Cc:

Description

Missing "Download" action on small screen resolution.

See attached screenshots.

Attachments (5)

theme-preview-download-btns-1.png (289.9 KB) - added by ramiy 4 years ago.
theme-preview-download-btns-2.png (96.1 KB) - added by ramiy 4 years ago.
meta-1272.patch (690 bytes) - added by ramiy 4 years ago.
meta-1272.2.patch (1.3 KB) - added by ramiy 4 years ago.
RTL & LTR
theme-preview-download-btns-with-patch.png (169.4 KB) - added by ramiy 4 years ago.

Download all attachments as: .zip

Change History (11)

@ramiy
4 years ago

#1 @ramiy
4 years ago

  • Keywords has-patch added

@ramiy
4 years ago

RTL & LTR

#2 @ocean90
4 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 1929:

WordPress.org Themes: Don't hide the download button on narrow screens.

Props ramiy.
Fixes #1272.

#3 @obenland
4 years ago

That was actually by design. Why would you need to download WordPress on your mobile device?

#4 @ocean90
4 years ago

Responsive != Mobile. Also, why not installing a theme from a mobile device? ¯\_(ツ)_/¯

#5 @ramiy
4 years ago

Konstantin, I agree with Dominik, Responsive != Mobile.

If, for example, I open the theme page in an narrow iframe in my site, for my users. It's desktop view - not mobile.

In this case, I would like my users to be able to download the theme.

#6 @obenland
4 years ago

I'd be surprised if that was true for 80%+ of users on small screens.

Note: See TracTickets for help on using tickets.