WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1273 closed defect (duplicate)

Handbook chapters list doesn't collapse on small screens

Reported by: morganestes Owned by:
Milestone: Priority: normal
Component: Handbooks Keywords: has-patch 2nd-opinion needs-testing
Cc:

Description

When I visit the core contributor handbook on a small screen/mobile device, the chapter list gets very long and unwieldy as I have to scroll a long way to get to the page content. The chapter widget heading has an indicator that makes it seem like it should be collapsible, but tapping it does nothing.

https://cldup.com/kKCxtZ47pd.png

Change History (7)

#1 @morganestes
4 years ago

  • Keywords has-patch 2nd-opinion needs-testing added

I don't have a dev environment set up for Make/Core yet, but I was able to put a script together in the browser to toggle the chapter list. It could use some work, but here's a sample:

var chapterHeading = jQuery( '.widget_wporg_handbook_pages .widgettitle' );

chapterHeading.click( function() { 
    jQuery( this ).next( '.menu-table-of-contents-container' ).toggle();
});

#2 @samuelsidler
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #467, really. @morganestes: If you work up some simple code that works on mobile (and only on mobile), I'll gladly commit it. :)

#3 @morganestes
4 years ago

Ahh, my searches missed that ticket. Okay, I'll work on that one and see what kind of patch I can come up with.

#4 follow-up: @iandunn
4 years ago

I think this might be more than just a mobile issue. @saurabhshukla was just pointing out the other day how bad the UX is on http://make.wordpress.org/community/handbook/, where there are actually 4 different handbooks, two of which aren't even filled out yet.

The list is already unwieldy for viewers, and it'll get twice as bad once the other two handbooks are done.

#5 in reply to: ↑ 4 @samuelsidler
4 years ago

Replying to iandunn:

I think this might be more than just a mobile issue. @saurabhshukla was just pointing out the other day how bad the UX is on http://make.wordpress.org/community/handbook/, where there are actually 4 different handbooks, two of which aren't even filled out yet.

The list is already unwieldy for viewers, and it'll get twice as bad once the other two handbooks are done.

That's separate to this ticket. :)

But I think in those cases the team should have multiple handbooks on their site instead of one handbook with multiple handbooks inside of it. The plugin handles that (see developer.wordpress.org), but it would need to be setup to do that and likely some UI added for it.

This ticket was mentioned in Slack in #outreach by saurabh. View the logs.


4 years ago

This ticket was mentioned in Slack in #outreach by iandunn. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.