WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

#1308 closed defect (fixed)

Inconsistent usernames and URLs on wordpress.org

Reported by: henrywright Owned by: ocean90
Milestone: Priority: normal
Component: Profiles Keywords:
Cc:

Description (last modified by netweb)

Migrated from https://core.trac.wordpress.org/ticket/25609


I have two accounts at wordpress.org.

  1. Registered on September 13, 2011


Username: henry.wright
URL: http://wordpress.org/support/profile/henrywright

  1. Registered on September 26, 2012

Username: henrywright
URL: http://wordpress.org/support/profile/henrywright-1

This results in one user having the username of 'henrywright' and another user having the URL of 'henrywright'.

My question - With reference to the second account (registered on September 26, 2012), at the point of registration should I have been told me that the username 'henrywright' was already taken?

Change History (13)

#1 @netweb
4 years ago

  • Cc henry.wright added
  • Description modified (diff)
  • Reporter changed from chriscct7 to henrywright

Restored original ticket formatting for improved readability.

#2 follow-up: @henry.wright
4 years ago

Thanks @netweb! Are henrywright and henry.wright the same now thing have been moved to meta.trac?

Last edited 4 years ago by henry.wright (previous) (diff)

#3 in reply to: ↑ 2 @netweb
4 years ago

Replying to henry.wright:

Thanks @netweb! Just to point out the original reporter is now henrywright (note there's no dot). Are henrywright and henry.wright the same?

I used the original usernames in the original ticket, henrywright as the reporter and comments as henry.wright

Both of the above profiles redirect to the same profile https://profiles.wordpress.org/henrywright

Though per the original report it is about usernames already taken should show a warning and not create a new user with a suffix of -1.

A couple more comments from the original ticket for more context:

Quoting ocean90:

Maybe it has been fixed, but when I try to register a new account with my username I get a "Name already exists" error.

Quoting henry.wright:

The way to reproduce:

  1. Register a username containing a dot e.g user.name
  2. Then register the same username without the dot e.g username

#4 @netweb
4 years ago

  • Keywords close added

I just tried to create a new user using the same username netweb and the user is not created with a warning "Name already exists"

https://cldup.com/bORwmnLUEA.png

Suggesting close here now as cannot reproduce.

#5 @henry.wright
4 years ago

I just tried to create a new user using the same username netweb and the user is not created with a warning "Name already exists"

Thanks for testing but that test isn't quite right because you seemed to have missed out the important dot from your tests.

Try these steps:

  1. Create a user with a dot in the username. For example abc.def
  2. Create the same username without the dot abcdef

#6 @henry.wright
4 years ago

  • Keywords close removed

#7 @SergeyBiryukov
4 years ago

  • Component changed from General to Profiles

#8 @SergeyBiryukov
4 years ago

  • Keywords needs-patch removed

Removing 'needs-patch' from components that are not open sourced yet, to help focus on tickets that actually need a patch.

This ticket was mentioned in Slack in #meta by ocean90. View the logs.


4 years ago

#10 follow-up: @ocean90
4 years ago

  • Owner set to ocean90
  • Status changed from new to reviewing

The plan is to only support a-z and 0-9 for usernames.

#11 in reply to: ↑ 10 @henry.wright
4 years ago

Replying to ocean90:

The plan is to only support a-z and 0-9 for usernames.

+1 from me.

The challenge will be how to handle existing usernames that already make use of a non a-z 0-9 character.

#12 @ocean90
4 years ago

In 2474:

Support Forums: Enhance styling of the register form.

See #1308.

#13 @ocean90
4 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

Since [dotorg11555] only a-z and 0-9 are allowed for usernames.


The challenge will be how to handle existing usernames that already make use of a non a-z 0-9 character.

Those will remain and are unaffected by the change.

Note: See TracTickets for help on using tickets.