WordPress.org

Making WordPress.org

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#1404 closed defect (duplicate)

Change how translate.wordpres.org works for Plugin and Theme developers

Reported by: amandato Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

I've looked through the trac and did not find a similar ticket. At present there are serious fundamental issues with the way translate.wordpress.org functions for theme and plugin developers.

At present plugin and theme developers must request who can make translations to their plugins. Plugin and theme developers also do not have translate capabilities by default.

I am requesting the following features for plugin and theme developers:

  1. Plugin and theme authors have full control who can translate their plugin, which languages and can add/remove translators at any time. Plugin authors should be able to add themselves as translators.
  1. Plugin and theme authors should have the ability to decide if a translator has "full translation control" or if their translations should be moderated (validators).
  1. Plugin and theme authors should have the ability to decide who moderates (choose validators) for their translations.

Change History (2)

#1 @ocean90
4 years ago

  • Component changed from International Sites (Rosetta) to translate.wordpress.org
  • Priority changed from high to normal
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1338 and please take a look at http://make.wordpress.org/meta/handbook/documentation/translations/.

If you have further questions don't hesitate to ask in Slack channel #meta-i18n.

This ticket was mentioned in Slack in #meta-i18n by angelomandato. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.