WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 6 weeks ago

Last modified 6 weeks ago

#1513 closed enhancement (fixed)

Theme Upload page confusion reducing enhancements

Reported by: mapk Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords: has-patch has-screenshots
Cc:

Description (last modified by Otto42)

This ticket was originally to add a new description to the uploader. Ticket #1514 was about adding a checkbox to confirm licensing and such.

Since these are both about changing the uploader page in similar ways, then let's consolidate the ticket to any relevant changes to prevent the problem of people uploading themes that are not theirs, possibly from confusion related to themes acquired from elsewhere and intended to be uploaded to their own sites.

Changing description and checkbox have been suggested. Other suggestions are welcome.

Attachments (2)

35410.diff (610 bytes) - added by mapk 2 years ago.
The number on the patch doesn't match the ticket b/c I created a ticket in the wrong place already. But this should work.
iagree.diff (1.9 KB) - added by rabmalin 8 months ago.
Adding I agree checkbox

Download all attachments as: .zip

Change History (17)

@mapk
2 years ago

The number on the patch doesn't match the ticket b/c I created a ticket in the wrong place already. But this should work.

#2 @Otto42
2 years ago

We already have an interim page that you have to go through:

https://wordpress.org/themes/getting-started/

Do we really need to add more?

#3 @mapk
2 years ago

@Otto42 - based on the amount of people that still upload their themes thinking they're uploading them to their site, unfortunately, yes. This is a minor text change that might help that issue.

There are other solutions being discussed which will have a broader affect, but will also take more time. This is quick and might make a difference.

Last edited 2 years ago by mapk (previous) (diff)

#4 @karmatosed
2 years ago

Noting we have: #1514 as an option to add in a checkbox. Perhaps this can be combined? Also should this be in directory or theme review?

Last edited 2 years ago by SergeyBiryukov (previous) (diff)

#5 @Otto42
2 years ago

#1514 was marked as a duplicate.

#6 @Otto42
2 years ago

  • Description modified (diff)
  • Summary changed from Add clearer description for Theme Upload page to Theme Upload page confusion reducing enhancements

@rabmalin
8 months ago

Adding I agree checkbox

#7 @rabmalin
8 months ago

Patch added for adding checkbox while theme upload.

This ticket was mentioned in Slack in #themereview by rabmalin. View the logs.


8 months ago

#9 @williampatton
7 months ago

Since this is the ticket where various changes to the theme directory upload page are collated there is another issue worth noting.

The page states 25mb upload limit on themes. In practice it turns out that the default php upload limit of 10mb is at play. We should sync the 2 values.

I think that 10mb is large enough size limit (does anyone disagree?) so the easiest fix is to change the text on this page to say 10mb. Alternatively the upload limit could be raised to 25mb but that would be a more involved change than just a text swap.

#10 @obenland
6 weeks ago

In 6345:

Themes: Make sure folks understand this is a submission.

Apparently there is still confusion around whether users can upload themes to their sites from here.

Props mapk.
See #1513.

#11 @obenland
6 weeks ago

I'd like to avoid adding a checkbox unless we absolutely have to. I'd rather display a big red banner that this is not a page to upload themes to one's site.

#12 @obenland
6 weeks ago

@williampatton Have you had trouble uploading a theme bigger than 10MB? upload_max_filesize is currently set to 50MB

#13 follow-up: @williampatton
6 weeks ago

@obenland personally I have not had an issue as I have never uploaded a theme over 10MB.

It's been reported in the Theme Review slack channel a few times though in the past. I may be misremembering but I think it was Otto that confirmed for one of the people that had trouble to be 10MB max.

Is the post_max_size set to 50MB as well?

#14 in reply to: ↑ 13 @obenland
6 weeks ago

  • Resolution set to fixed
  • Status changed from new to closed

Replying to williampatton:

Is the post_max_size set to 50MB as well?

It is, yes.

Would you mind pinging me if you come across someone having that problem again? I'm happy to take a look on a concrete example. Closing for now.

#15 @williampatton
6 weeks ago

Can do :)

Note: See TracTickets for help on using tickets.