WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1759 closed defect (fixed)

BuddyPress Trac tickets with IDs lower than 856 do not open.

Reported by: DJPaul Owned by: nacin
Milestone: Priority: high
Component: Trac Keywords:
Cc:

Description

"Trac detected an internal error: AttributeError: 'NoneType' object has no attribute 'lower'"

Broken: https://buddypress.trac.wordpress.org/ticket/855
Working: https://buddypress.trac.wordpress.org/ticket/856

Change History (9)

This ticket was mentioned in Slack in #buddypress by djpaul. View the logs.


3 years ago

#2 @netweb
3 years ago

Here's some more sample tickets, some work, some do not:
https://buddypress.trac.wordpress.org/ticket/854 works
https://buddypress.trac.wordpress.org/ticket/853 does not work
https://buddypress.trac.wordpress.org/ticket/852 works
https://buddypress.trac.wordpress.org/ticket/851 does not work
https://buddypress.trac.wordpress.org/ticket/850 does not work
https://buddypress.trac.wordpress.org/ticket/849 works
https://buddypress.trac.wordpress.org/ticket/848 does not work
https://buddypress.trac.wordpress.org/ticket/847 works
...
https://buddypress.trac.wordpress.org/ticket/817 works
https://buddypress.trac.wordpress.org/ticket/816 does not work
https://buddypress.trac.wordpress.org/ticket/815 does not work
...

https://buddypress.trac.wordpress.org/ticket/715 works
https://buddypress.trac.wordpress.org/ticket/714 does not work
https://buddypress.trac.wordpress.org/ticket/713 does not work
https://buddypress.trac.wordpress.org/ticket/712 does not work
https://buddypress.trac.wordpress.org/ticket/711 does not work
https://buddypress.trac.wordpress.org/ticket/710 does not work
https://buddypress.trac.wordpress.org/ticket/709 does not work
...
https://buddypress.trac.wordpress.org/ticket/608 does not work


In the error message is this:

To that end, you could Create a ticket.

Which results in:

Request-URI Too Large: The requested URL's length exceeds the capacity limit for this server.

That "Create" link above is 11,953 characters long and is attempting to create a ticket with some browser debug info such as my Trac username, Browser Agent, even includes wporg_sanitize_user_nicename in that link ¯\_(ツ)_/¯

This ticket was mentioned in Slack in #buddypress by netweb. View the logs.


3 years ago

#5 @slaFFik
3 years ago

  • Priority changed from normal to high

Based on the error text, perhaps those tickets were created by already deleted user? So change.author variable doesn't have required content, and thus - template is breaking.
Not sure, just a suggestion.

This issues hugely prevents us from cleaning up the BuddyPress trac. Would be really nice to have it fixed.

This ticket was mentioned in Slack in #meta by djpaul. View the logs.


3 years ago

This ticket was mentioned in Slack in #meta-tracdev by djpaul. View the logs.


3 years ago

#8 @nacin
3 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 3736:

Trac: Catch exception that appears to be caused by anonymous users. fixes #1759.

This ticket was mentioned in Slack in #buddypress by djpaul. View the logs.


3 years ago

Note: See TracTickets for help on using tickets.