WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#2162 closed defect (fixed)

Support Theme: Post notices push content down

Reported by: Clorith Owned by: SergeyBiryukov
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

The clear: both from bb core is causing some headaches in the new theme with displaying post content, as they drop down to below the author section.

Applying a clear: none to .bbpress #bbpress-forums div.bbp-template-notice in https://wordpress.org/support/wp-content/themes/pub/wporg-support/sass/site/_bbpress.scss sorts out the pushing of notices.

Attachments (1)

meta-2162.png (38.1 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (12)

#1 @SergeyBiryukov
3 years ago

A screenshot would be helpful here.

#2 @Clorith
3 years ago

Ahh of course, forgot to add them, here they come:

The current display of a post if it has a notice
http://imgur.com/By0jS15.png

Here is the same view if we introduce the clear: none
http://imgur.com/9a262WW.png

#3 @SergeyBiryukov
3 years ago

  • Summary changed from Forum Theme: Post notices push content down to Support Theme: Post notices push content down

The border on the notice is also missing, and it's hard to see light orange on light pink.

@mapk: Is that intentional? In the old theme, the notice was much more... noticeable :) See meta-2162.png.

#4 @mapk
3 years ago

This was not intentional.

Overall, dropping the borders from the notifications is a design decision I was hoping to implement throughout the site (http://codepen.io/mapk/pen/dpwmYw), but I didn't realize they showed up on top of the light pink forum replies.

Can we drop the background of these replies since there's a notification? Isn't the notification enough to signify the status of this reply?

Also, I notice these replies don't follow the layout of the new forum replies. We should probably fix that. Maybe a new ticket? I also noticed the pending replies page needs a lot of work.

Last edited 3 years ago by mapk (previous) (diff)

#5 @Clorith
3 years ago

I'd be more than happy to see the background colours go away, they reduce readability even for those with "normal" eyesight.

#6 @netweb
3 years ago

The purpose of the background colors based on post status which is "by design" in bbPress core is to make highlighting posts with a quick visual queue, i.e. the reddish #fdd for spam, and yellowish #fef7f1 for pending, and the w.org specific archived status also using #fdd.

The addition of the template notices inside each topic or reply added in #1561 could allow the background to be removed for replies, though we'd need to come up with a solution for topics

A users replies view as how it would be seen by a moderator (padding issue not withstanding):

And the same users topics view as how it would be seen by a moderator:

A view of some pending WordPress comments:

  • https://cldup.com/ZooOnxB7hC.png

#7 @mapk
3 years ago

OK, I understand the argument for keeping the background colors. If this remains, we should look at adjusting the colors for the notifications within them.

I've been messing with notifications colors on this codepen: http://codepen.io/mapk/pen/dpwmYw and created some brighter notification colors for the purpose of showing on colored backgrounds. All notifications are a11y compliant. So basically we'd change them to be something like this:

Super bright spam warning
https://cldup.com/HmY_jA1XMY.png

Super bright pending warning
https://cldup.com/Bb-1rRnD1D.png

I imagine these super bright colors would only be used on the support forum section and not so much on the rest of the site. Any thoughts?

#8 @Clorith
3 years ago

The darker colours certainly improved readability while keeping the current expectations.

#9 @netweb
3 years ago

Looks good to me

#10 @SergeyBiryukov
3 years ago

The large gap was fixed in #2356, so let's just fix the colors here.

#11 @SergeyBiryukov
3 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 4718:

Support Theme: Adjust colors for notices indicating that a post is pending or has been flagged as spam.

Props mapk.
Fixes #2162.

Note: See TracTickets for help on using tickets.