WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 23 months ago

#2215 closed enhancement (wontfix)

copy translations to older versions

Reported by: qdinar Owned by:
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

i translated dev main po file 100% , https://translate.wordpress.org/locale/tt/default/wp/dev , and i see now in 4.6 it is also 100%. but 4.5 is not, and i searched an untranslated "You are logged in already. No need to register again!" of 4.5 and see it is translated in 4.6. why it is not copied to 4.5 but was copied to 4.6 from dev?

(dev main po file has nearly 400 new untranslated strings now, but 4.6 is 100% translated).

( dev is most fresh version, and i translated it, not 4.6, my translation was copied from dev to 4.6 ie to older version. why it is not also copied to 4.5? )

4.6 version is released august 16 this year and 4.6.1 at sep 7. i completed the po file in "dev" version later. so, it was automatically copied from dev to 4.6 not just at time 4.6 released, but later.

it would be good if strings (translations) copied automatically (to other versions). and maybe that was planned, but there is a bug.

(copying from https://wordpress.slack.com/archives/polyglots/p1477913102003885 ).

Change History (2)

#1 @obenland
23 months ago

  • Component changed from General to Translate Site & Plugins

#2 @ocean90
23 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Only during a release transition translations are copied to a new branch. New translations are not synced by design.
You have to use the import/export functionality if you want to use a new translation in an older version too.

Note: See TracTickets for help on using tickets.