WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2604 closed defect (fixed)

Plugin Search ranking for plugins with more than 1 million installs broken

Reported by: gibrown Owned by: tellyworth
Milestone: Plugin Directory v3.0 Priority: high
Component: Plugin Directory Keywords:
Cc:

Description

The ranking function for plugin installs only considered the active install range from 0 to 1 million. The recent-ish change that has some plugins at over 1 million (6 total) has caused their scores to be significantly dropped (by about 48%). Effectively, it makes a 3 million install plugin look like a 90k install plugin.

The cause is a hack that provides more differentiation between plugins with 100k installs and 1m installs. Rather than the curve being logarithmic in this range it is linear. To fix it we only apply that hack when active installs are less than 1m. Above 1m the curve is logarithmic again so that the high install plugins don't get boosted by too much.

installs : multiplier
100k : 3.23801591197
500k : 4.1940446601
1mil : 5.18081720924
2mil : 5.44074702695
3mil : 5.59279631749
10mil : 6.04428594411

This fix shouldn't ever break in the same way. It may not be ideal for differentiation between high install plugins, but there are not that many of them right now, so it's a problem for ten years from now.

Attachments (1)

3mil.diff (755 bytes) - added by gibrown 2 years ago.
Patch to not apply decay to plugins with 1m plus installs.

Download all attachments as: .zip

Change History (6)

@gibrown
2 years ago

Patch to not apply decay to plugins with 1m plus installs.

#1 @lukecavanagh
2 years ago

@gibrown

On form plugin search words, Formidable Forms with 300,000+ active installs only shows up on page 2 of the search results.

https://wordpress.org/plugins/search/form+plugins/page/2/

#2 @gibrown
2 years ago

@lukecavanagh I think that is a separate issue from this ticket. This change shouldn't (and doesn't appear to) have any impact on this particular search. Maybe we should open a new ticket for this and any other cases discovered in the short term? I think with the launch of the directory there will be a number of other cases like this.

Looking at Formidible Forms in particular, I am pretty sure part of the reason it is ranking lower is because it has zero resolved support threads. Most of the plugins above it have similar or higher ratings, but substantially more support threads resolved. It's a very competitive landscape so it's tough to be sure without looking at it in more depth than I can right now. I agree that it looks a little funny/surprising.

#3 @lukecavanagh
2 years ago

@gibrown

Opened a new ticket for it #2617

This ticket was mentioned in Slack in #meta by gibrown. View the logs.


2 years ago

#5 @tellyworth
2 years ago

  • Owner set to tellyworth
  • Resolution set to fixed
  • Status changed from new to closed

In 5199:

Plugin directory search: fix ranking algorithm for plugins with 1m+ active installs. Props @gibrown.

Fixes #2604

Note: See TracTickets for help on using tickets.