WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2735 closed defect (fixed)

Support Forums: Committers can't mark plugin threads resolved

Reported by: Shelob9 Owned by:
Milestone: Priority: high
Component: Support Forums Keywords:
Cc:

Description

Both the "Reply and mark resolved" and the status update form in the sidebar are missing for me. This is an essential tool for organizing support, please restore this functionality.

Change History (8)

#1 @Shelob9
2 years ago

  • Priority changed from highest omg bbq to normal

Might be related to my account. I can mark threads resolved in Pods, where I am a contributor, but not in Caldera Forms, where I am the plugin author. I can in other plugins I am a contributor to.

#2 @Ipstenu
2 years ago

  • Priority changed from normal to highest omg bbq
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2699.

That is. Only contributors can close tickets as resolved. We're talking about a new role though!

#3 @Ipstenu
2 years ago

  • Component changed from General to Support Forums
  • Priority changed from highest omg bbq to high
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Summary changed from Ability to mark support tickets as resolved is missing form plugin support forum to Support Forums: Committers can't mark plugin threads resolved

Okay this was misrepresented due to a misunderstanding of the roles. It's confusing.

If you have COMMIT access, it supersedes everything else. Josh has commit access on all the plugins, but on ONE he was not able to change a post status to resolved.

The current issue is that two (to date) committers of plugins have not been able to mark posts as resolved. In ONE case, the fix was to remove his commit access and restore it.

Last edited 2 years ago by Ipstenu (previous) (diff)

#4 @coffee2code
2 years ago

In 5327:

Support Forums: Re-query for authors or contributors if an empty array was cached.

See #2710, #2735.

#5 @coffee2code
2 years ago

@Shelob9: Is the access in question now restored for you?

#6 @Shelob9
2 years ago

@coffee2code Yes, that fixed it. Thank you.

#7 @coffee2code
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

#8 @SergeyBiryukov
2 years ago

To clarify a bit, this was another manifestation of #2710, nothing to do with #2699.

Note: See TracTickets for help on using tickets.