WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#2760 closed defect (duplicate)

Bring back the "Translate this Plugin" link/button

Reported by: webdevmattcrom Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

In the old Plugin Directory design there was a "Translate this Plugin" button that led to a central translate.wordpress.org link for users to contribute to Plugin translations directly. That doesn't exist at all in the new directory and navigating there is very cumbersome.

I'd suggest it emulate the Donate section in the sidebar. Here's the basic concept:
https://i.imgur.com/72esmsh.png

Most likely that button will be dynamic based on the locale the visitor is viewing the particular plugin on. E.g. the German page for the GIVE plugin: https://de.wordpress.org/plugins/give/ the Translate button would go to the German translate page for the GIVE plugin:
https://translate.wordpress.org/locale/de/default/wp-plugins/give

Change History (2)

#1 @ocean90
2 years ago

  • Milestone Plugin Directory v3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2692.

#2 @SergeyBiryukov
2 years ago

  • Component changed from General to Plugin Directory
Note: See TracTickets for help on using tickets.