WordPress.org

Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#2761 closed defect (duplicate)

Correction needed of placeholder key in gettext string

Reported by: tobifjellner Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/plugin-directory/shortcodes/class-upload-handler.php?marks=91#L91

return sprintf( __( 'Sorry, the plugin name %1%s is reserved for use by WordPress. Please change the %2$s line in your main plugin file and upload it again.', 'wporg-plugins' ),

%1%s should be changed to %1$s

Change History (4)

#1 @tobifjellner
2 years ago

On more place:
https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/plugins/plugin-directory/shortcodes/class-developers.php?marks=73#L73

                                      /* translators: 1: plugin name, 2: number of locales, 3: list of locales */
_n(
'“%1$s” has been translated into these %2$d locales: %3$s.',
'“%1$s” has been translated into these %2$d locales: %3$s.',
$locales_count
),
$title,
$locales_count,
$locales_list
) . ' ';
}

First occurence of
'“%1$s” has been translated into these %2$d locales: %3$s.'
Should be changed to singular, i.e.
'“%1$s” has been translated into this %2$d locale: %3$s.'

#2 @ocean90
2 years ago

  • Priority changed from high to normal
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2757.

The wrong placeholder has been fixed in [5401].

The other string is correct, see https://meta.trac.wordpress.org/ticket/2694#comment:3 for background.

#3 @tobifjellner
2 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

The main topic in this ticket is to correct an error that was introduced by #2757, i.e. placeholder text %1%s instead of %1$s

#4 @ocean90
2 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #2757.

Please read my comment again:

The wrong placeholder has been fixed in [5401].

Note: See TracTickets for help on using tickets.