WordPress.org

Making WordPress.org

Opened 11 months ago

Closed 4 months ago

#2874 closed defect (duplicate)

Videos list order is not correct on search

Reported by: mgelves Owned by:
Milestone: Priority: low
Component: WordPress.tv Keywords:
Cc:

Description

I did a search for WordCamp Denver videos in the wordpress.tv website using the keyword "denver" and it returns first the videos from 2009 and then from the 2016 edition.

http://wordpress.tv/?s=denver

I think the best way to return the results should be order by year and in descendant way.
E.G:
WordCamp Denver 2016
WordCamp Denver 2015
WordCamp Denver 2014
and so on...

Attachments (1)

Screen Shot 2017-06-15 at 15.09.48.png (502.3 KB) - added by mgelves 11 months ago.

Download all attachments as: .zip

Change History (4)

#1 @Otto42
11 months ago

  • Component changed from General to WordPress.tv

This ticket was mentioned in Slack in #meta by obenland. View the logs.


4 months ago

#3 @dd32
4 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

After looking at this, it's mostly working as expected.

Videos are searched for where the post_content or post_title have denver in it, and then the results are sorted by post_title containing denver and then by date (2017..2016.....2009).
The 2009 Denver videos contain the phrase Denver in the post_title, so they get returned first. It's a poor attempt at relevancy.

Attempting to search for something more realistic, such as https://wordpress.tv/?s=capabilities results in results which look far more promising.

I think there's probably some worthwhile changes we can make here, such as searching category names and showing any matching categories of videos, but I think that'll be better solved through #3387.

I'm going to mark this as a duplicate of #3387 and add a comment there to this effect.

Note: See TracTickets for help on using tickets.