WordPress.org

Making WordPress.org

Opened 6 years ago

Closed 2 years ago

#305 closed enhancement (fixed)

Prevent marking a ticket as duplicate of itself

Reported by: TobiasBg Owned by: SergeyBiryukov
Milestone: Priority: low
Component: Trac Keywords: has-patch
Cc:

Description

Looks like Sergey tried some magic: :-)
https://core.trac.wordpress.org/ticket/27004

Can we maybe prevent marking a ticket as a duplicate of itself?

Attachments (1)

305.patch (933 bytes) - added by SergeyBiryukov 2 years ago.

Download all attachments as: .zip

Change History (5)

#1 @samuelsidler
3 years ago

This could probably be done with some JS instead of server-side validation. Anyone want to take a stab?

#2 @samuelsidler
3 years ago

  • Priority changed from normal to low

@SergeyBiryukov
2 years ago

#3 @SergeyBiryukov
2 years ago

  • Keywords has-patch added

When marking a ticket as a duplicate without specifying a number, it gets closed without a resolution (previously mentioned in #112 and comment:4:ticket:273).

When marking a ticket as a duplicate of itself, it's just confusing (see #WP27004).

305.patch prevents both issues.

#4 @SergeyBiryukov
2 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 5907:

Trac: Prevent marking a ticket as a duplicate of itself.

Fixes #305.

Note: See TracTickets for help on using tickets.